Support » Plugin: Ozpital WPWeTransfer » Sorry to be a bother but you need Javascript enabled to upload

  • Resolved VSOC Webmaster

    (@vsoc-webmaster)


    Hi,
    Installation went well, but when I add in the shortcode to a page or post I get the message “Sorry to be a bother but you need Javascript enable to upload.” in my preview screen. When I view the page live, I am unable to upload and get the message “Transfer Failed”

    I am using WP 4.9.8 with “X” theme and PHP 7.0

    Many thank in anticipation of your help.

    Nick

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey, I’m also looking for help so I decided to look elsewhere since the developer doesn’t appear to be around. I did read in one thread that the emails were going to spam or something so he might not be seeing them.

    http://bit.ly/2PButXI

    • This reply was modified 8 months, 1 week ago by  greyhood.
    Plugin Author ozpital

    (@ozpital)

    Hello, that’s an odd one @vsoc-webmaster and thanks for the link to check it out.

    Poking around Chrome dev tools reveals that this issue might be related to anti-spam.

    It might be a case that the my WeTransfer plugin needs white-listing in any anti-spam/security plugins you have installed. I’m happy to work with you to solve this one as I’m sure others will come up against it too.

    If you can list your plugins here that will be helpful; unless you already know what one we should be looking at 😉

    Hi Ozpital,

    I’ve updated your plugin…

    So, deactivating WP-Spamshield lets the upload happen, but there’s still that Javascipt notice. I can upload a file and a link to download is shown, but no option to add email to and from, so no notifications to the sender or intended receiver.

    Within WP-Spamshield if I check “Disable anti-spam for miscellaneous forms.” then I can upload files, but still no email section. Should I be seeing the email section?

    Thanks
    Nick

    Hi Ozpital,

    I understand now that there is no email section for your plugin… but, I can’t see anything in the admin page for this:

    I’ve release an update to the plugin which adds a textarea to add your success event javascript easily.

    I’m not going to teach you javascript but I assure you this is very easy to do. I’ve hopefully made it even easier with the provided CF7 example I’ve added to the admin page

    I’ve even added the CF7 plugin…

    Plugin Author ozpital

    (@ozpital)

    Crap. I’ve just tested again on my live machine and you’re correct. The box isn;t appearing.

    I’ll sort that out now. Sorry for this confusion.

    Bare with me.

    Plugin Author ozpital

    (@ozpital)

    An update to the plugin should have filtered through to you by now @vsoc-webmaster .
    Let me know if you hit any issues with it.

    Thanks – I’ve got it.
    Now I just need to play a bit with CF7 (never used it before)
    Cheers.

    Plugin Author ozpital

    (@ozpital)

    Great! I think the only tip I need to give you now is to ensure you add a unique ID to the required CF7 form field so you can use the document.getElementById as in the example.

    Have fun sussing it all out. This should hopefully help with future projects too 😉

    Cool. I’ll have a play. Topic resolved 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Sorry to be a bother but you need Javascript enabled to upload’ is closed to new replies.