Support » Plugin: Lf Hiker » Sorry, this file type is not permitted for security reasons

  • Resolved jd0127

    (@jd0127)


    Not sure if this is a plugin issue or wordpress configuration issue. When I try to upload a GPX file wordpress gives me “Sorry, this file type is not permitted for security reasons” I tried both the built-in file uploader and the multi file uploader. How do I fix this? Thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • CCRussell

    (@ccrussell)

    I have two ways to get around that in my system. There are more.

    First way, that I used for a year or so, was to upload the file to a folder using FTP, and then creating the shortcode manually, using that.

    Now, however, I’ve found a plugin that resolves the issue for me. Upload “WP Add Mime Types” and in Settings/Mime Type Settings add the following info for this type:

    gpx = application/gpx+xml

    Once you save that setting, you can use the media uploader for GPX files.

    You can also turn off the error by editing your WP Config PHP file, but I don’t recommend that as it opens up a security issue.

    jd0127

    (@jd0127)

    Thank you. Got it to work. I appreciate your help.

    CCRussell

    (@ccrussell)

    My pleasure! I do like this plugin, I use it a lot in my website

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Sorry, this file type is not permitted for security reasons’ is closed to new replies.