Support » Theme: OceanWP » “Sorry, the content area was not found in your page. You must call the_content

  • Nicolas;

    I have been trying to help a user (which has now turned into users) who are running various configurations of Elementor and the Ocean WP theme. Some are free on both versions, some are pro. Anyway, there are a bunch of users who are getting the following error:

    “Sorry, the content area was not found in your page. You must call the_content function in the current template, in order for Elementor to work on this page.”

    I have had them try everything from disabling all of their plugins, to cache, to php memory increases, making sure Ocean extras is installed and all add-ons turned on, un-install and re-install both the Elementor plugins, the theme, the add-ons, etc.

    Is there anything you can think of that we could try to help these users with this error. It is happening with the current versions of Elementor and Ocean WP.

    Thanks for any assistance suggestions you can offer.

    Cheers!!!

    Shawn Campbell

Viewing 9 replies - 1 through 9 (of 9 total)
  • Theme Author oceanwp

    (@oceanwp)

    Hello, try to re-generate the permalinks via Settings > Permalinks, you can also contact the Elementor support team to know if it is a bug with OceanWP only or a bug with many themes.

    Tried that and it did not work. One user was a Generate Press user and the fix was to switch the loader method to enabled. The respective users have contacted Elementor with no resolution as of yet. Thanks for getting back with one possible solution.

    Shawn

    Theme Author oceanwp

    (@oceanwp)

    Hi, can you tell me what Elementor respond? I will know what to do to solve this issue for future users.

    The usual, clear your caches, disable plugins, make sure that the them has the php code to show the content (which yours does and myself and a lot of other users are NOT having issues), the usual blanket answer response.

    Theme Author oceanwp

    (@oceanwp)

    Hi, you need to tell them that you did all that and the theme has the “the_content” but it still doesn’t work.
    The pages you have this issue are normal pages, right? Not blog, shop, etc…

    Apparently in this case, the archive page. What pages are not allowed to be edited with Elementor and why? That way I can better help to support these posts or questions. I do not remember seeing this documented anywhere.

    Thanks…

    Shawn

    Theme Author oceanwp

    (@oceanwp)

    In that case, it is normal, as it is archive page, it is not possible to use a page builder to edit it directly. But with Elementor Pro 2.0, now you can edit the archive pages via Elementor > My Templates.

    Not true. You can edit archive pages.

    Theme Author oceanwp

    (@oceanwp)

    Hello @barrychapman, this topic is from 5 months ago 🙂
    Yes, now with Elementor Pro 2.0, it is possible to edit archives pages.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘“Sorry, the content area was not found in your page. You must call the_content’ is closed to new replies.