Support » Fixing WordPress » Sorry, that file cannot be edited

  • Resolved sharecentric


    I have just upgraded to 2.2.1, though I do not think it is related.

    Whenever I try to edit any theme (all of the many many that I have), I get “Sorry, that file cannot be edited.” I have tried changing permissions, reuploading the theme, reuploading the theme-editor.php, I even upgraded PHP on my account to 5, with no success. This seemed to have happened out of the blue, I was editing fine Sunday, and now on Monday it is giving me this error. Is there debug/logging I can turn on to see whats going on or does someone know what is going on under the hood so I can troubleshoot this?

    The only other symptom, and it seems related, is that the Plugin editor is also not functioning properly. It is “stuck” on editing “wpg2/wpg2.php” which is my WP gallery2 plugin. No matter what plugin I pick to edit, it is always editing that one. It allows me to edit it, and seems to save alright, but again I can not pick another plugin to edit.

    Any ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have searched through the other posts that are older. There is a ticket with this problem, however it appears to have been solved. That one also involved strange characters. I cannot edit any theme, even ones with simple 1 word, alpha names, with no spaces or special characters.

    Anyone else having this problem or have any suggestions?

    I found the problem. The beta WPG2 plugin was causing the conflict. When it is disabled I can edit files again. I will take it up/try the stable or new nightly version of that plugin.

    When I’ve updated my Wp installation from WP 2.3RC to WP 2.3 final I had this problem too…

    When I try to go to the themes or plugins editor I receive the error:
    “Sorry, that file cannot be edited.”

    I’ve tried to disable all my plugins but I receive the error anyway…

    No one can help me? 🙁

    Posting in a resolved thread will not get you an answer. Create a new thread of your own. Anyway it’s a permissions problem look here.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Sorry, that file cannot be edited’ is closed to new replies.