Support » Plugin: Kebo Twitter Feed » Sorry, no Tweets were found

  • Plugin Author Peter Booker

    (@peterbooker)


    Hi guys,

    I have had reports of users installing the plugin and setting up their connection to Twitter but never being able to display Tweets.

    While these reports are very rare I would like to do everything I can to identify and resolve the problems. In light of this, I am asking that if anyone has problems which involve the plugin getting/displaying Tweets, identified by the Widget output showing “Sorry, no Tweets were found”, that they let me know here.

    It would also be very useful if you could let me know:

    1. Your version of WordPress
    2. The Hosting Provider
    3. Any plugins you use

    All the feedback I get helps me to narrow down the potential issues and focus in on the things which really cause people problems, so I really appreciate it.

    http://wordpress.org/plugins/kebo-twitter-feed/

Viewing 15 replies - 1 through 15 (of 61 total)
  • jasonzeeman

    (@jasonzeeman)

    Hi,

    I am having this error since the plug in was updated a few days ago..

    My version of WordPress is 3.6
    My host in serv-hosting (south africa)

    Plugins used are:

    “best hit counter”,
    “insert headers and footers”
    “Kebo twitter feed”
    “soundcloud shortcode”

    http://www.jasonzeeman.com

    Plugin Author Peter Booker

    (@peterbooker)

    Thanks jasonzeeman,

    I will look through the differences in the last couple of updates and see if I can identify what caused this for you.

    jasonzeeman

    (@jasonzeeman)

    Hey Peter!

    I can see you’ve been hard at work on trying to fix the twitter feed problem. I installed the update and my site is still not fetching tweets?
    I even re installed wordpress but am having no luck.
    I no longer get a “sorry, no tweets were found” on my site, it just comes up empty and I’m unable to scroll down to my footer?

    Any thoughts / advise?

    Jason

    Plugin Author Peter Booker

    (@peterbooker)

    Hi jasonzeeman,

    I am sorry to hear you are still having problems. If I understand you correctly it sounds like it might now actually be causing an error too, blocking the page from fully rendering. Would you be able to check your error log to see if/what error it is causing?

    I am still at a loss to what causes situations like this. It still seems there is a problem with collecting the Tweets data.

    One possibility is that I compress the data response from Twitter using GZIP and while browsers decompress the GZIPd JSON data fine, perhaps some servers are struggling which is causing issues.

    I will be making a change in the next few days which will result in the response not being GZIP’d, so perhaps this will resolve the issue.

    jasonzeeman

    (@jasonzeeman)

    Hi Peter,

    Sorry for not replying sooner. I have checked the error log and:
    “Good news, there have been no errors received from Twitter recently.”

    I’ve tried pretty much everything from my side.. and no need to apologize. These things happen. I’m just happy for a great free plugin.

    Jason

    Plugin Author Peter Booker

    (@peterbooker)

    Hi jasonzeeman,

    After some extensive testing and help from some other people in the WP community (thanks Clorith). I have replicated what seems to be the problem by returning the data not GZIP’d, I had not considered some servers not being capable of decoding GZIP’d data.

    I want to do some more testing of my patch before it goes live and finish adding some of the other features part way done. Hopefully I will release this next patch by the weekend.

    Thnaks for all your support, your feedback on this issue has helped me to identify and hopefully fix something which will have caused many people problems.

    jasonzeeman

    (@jasonzeeman)

    Great news. Thanks for the support and good luck. Will keep my eyes open for the update!

    Hi Peter – I’ve just found this great plugin, set it up on my site and it worked fine. Then in the last 30 minutes it has just stopped working completely and I’m getting the “Sorry, no tweets to display” error.

    I then spotted that I needed to update the plugin, so did that, and it still didn’t help. I am using WP v3.5.1 (too old?!), Heart Internet (UK) and only have 3 plugins (none of them security ones) activated. Any ideas?

    Thanks so much,
    Fiona

    Plugin Author Peter Booker

    (@peterbooker)

    Hi fmevans,

    I was just coming here to post an apology. A change I made to the script a little while ago (30-60mins), which altered the way data was transmited back to sites in an unexpected way, causing the plugin to begin showing “Sorry, no Tweets found!” on all sites (I think).

    I have reversed the change and will work on how I can safely implement the change at a later stage.

    The plugin should be working normally now, or from the next time it fetches the latest tweets.

    Sorry for the inconvenience caused, and please let me know if this problem continues after the next 15mins.

    ok – no problem at all – trust me to be working on it just as you were doing that!! 🙂 Thanks for letting me know. I’ll reactivate it.
    F

    Plugin Author Peter Booker

    (@peterbooker)

    No problem fmevans, sorry to have caused you problems. I will be more careful with updates in the future.

    I get “Sorry, no Tweets were found.” as well. Authentication seemed to go fine.

    Plugin Author Peter Booker

    (@peterbooker)

    Hi Narkan,

    Is there anything in the error log on the plugin’s options page? Is this using version 0.5.13?

    Hi Peter,
    I’ve just installed the plugin and I, too, am getting the “Sorry, no Tweets were found” output in the widget.
    Wordpress 3.5.1; Kebo 0.6.7; Twitter @richdavies21
    I’m using 8 other plugins: Akismet; Contact Form 7; Custom Sidebars; Events; Google Analytics for WordPress; List category posts; Updraft Plus; Widget Entries.
    The Twitter account is not very active and I don’t have control of it – it’s a client’s account and I don’t want to tweet from it. There have been no fresh tweets since I installed the Kebo plugin; will tweets only show up from this point on, or can the plugin grab that last 4-5 tweets any way?

    Plugin Author Peter Booker

    (@peterbooker)

    Hi Joolsjools,

    Sorry you are having problems too.

    When working correctly, it will grab the history of Tweets happily. It seems there are currently some big character encoding issues, which then corrupt the format of the Tweet data. Causing the “Sorry, no Tweets found” message, which is actually more like “Data was not in the expected format”.

    I am working on this until it is fixed, I am currently re-thinking the way I deal with the character encoding completely. I hope I can have it all resolved by tonight/tomorrow.

    Sorry again for the inconvenience.

Viewing 15 replies - 1 through 15 (of 61 total)
  • The topic ‘Sorry, no Tweets were found’ is closed to new replies.