Support » Plugin: WordPress Popular Posts » Sorry. No data so far >> that’s wrong

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @micampub09,

    Have you checked this FAQ yet? I’m getting “Sorry. No data so far”. What’s up with that? If not, then please check it out first and then come back here if you’re still having issues with the plugin.

    Thread Starter micampub09

    (@micampub09)

    all points of the FAQ have been checked, the problem is still there

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Alright. Did you also try the suggestions from the first FAQ? Does the issue persists even with all of the other plugins disabled? Did you try temporarily switching to a different theme as well?

    Thread Starter micampub09

    (@micampub09)

    yes I have to try, moreover it is a multisite wordpress, the other sites (example https://medecine.savoir.fr) have well generate toplists for the categories, but this site telecharger2.savoir.fr not. I have been using your toplist for over 2 years

    Plugin Author Héctor Cabrera

    (@hcabrera)

    I checked the source code of your website and it appears that you’re using AMP with it. If that’s the case then that would explain the issues you’re having with WPP. AMP doesn’t support third-party JS and so the WPP plugin won’t be able to work on your website reliably.

    Thread Starter micampub09

    (@micampub09)

    the amp mode is deactivated when I artificially generate the hits (which I have been doing for 1 year with amp without problem) when my toplist is generated I put in AMP.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Alright. Putting that aside, I’ll need more details to be able to help you out.

    For example: how are you building that “Top Categories” section? It doesn’t seem to be a WPP widget, what are you using there? And please be as much detail as possible.

    Thread Starter micampub09

    (@micampub09)

    <?php if(!is_category()or is_tag()){ ?>
    <div class=widget>
    <h3 class="widgettitle">Top Catégorie <?php $categories=get_the_category();if(! empty($categories)){echo esc_html($categories[0]->name);}?></h3>
    <?php foreach((get_the_category())as $cat){
    	$args=array(
    	  'cat' => $cat->cat_ID,
    	'title_length'=>70,
    	'excerpt_length'=>130,
    	'thumbnail_width'=>104,
    	'thumbnail_height'=>92,
    	'post_html' => '<li class=t> {thumb_img} {title} </li>',
    	'range' => 'all',
    	'limit'=>6,
    	
    	);wpp_get_mostpopular($args);} ?>
    </div>
    <?php } ?>

    it’s the same code i used before when it worked

    • This reply was modified 1 year, 6 months ago by micampub09.
    • This reply was modified 1 year, 6 months ago by micampub09.
    • This reply was modified 1 year, 6 months ago by Jan Dembowski. Reason: Formatting and that's not really something anyone should modlook
    Plugin Author Héctor Cabrera

    (@hcabrera)

    Your code is attempting to show the top posts from the categories assigned to the current post (see get_the_category()) so it should work when you visit a single post. Is that what you’re trying to do?

    Other than that, I don’t see anything odd with your code at first glance so no idea what’s going on.

    P.S.: when posting code here, please use the code button to wrap it. Alternatively, you may also upload it somewhere (eg. pastebin.com) and share the link instead.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Marking as resolved due to inactivity.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Sorry. No data so far >> that’s wrong’ is closed to new replies.