Support » Plugin: AMP » Working great for me now!

  • Bodhipaksa

    (@haecceity)


    My earlier review no longer applies. I have to say I’m very impressed with the way that the AMP plugin works in native mode, creating (as I understand it) AMP-friendly versions of my existing theme. Everything is working beautifully.

    It’s a slight pain that the admin bar is disabled, since I use that for seeing if comments are in moderation, but I can live with that.

    This plugin is barely functional. Sure, it generates AMP versions of posts, but with no navigation. If someone lands on one of my AMP blog posts they can’t navigate anywhere on my site except to the home page.

    And although I’ve enabled AMP on Pages, they display using the normal theme I have installed.

    There are almost no settings. There’s a lot of room for improvement.

    • This topic was modified 1 year ago by Bodhipaksa.
    • This topic was modified 1 year ago by Bodhipaksa.
    • This topic was modified 1 year ago by Bodhipaksa.
Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Weston Ruter

    (@westonruter)

    @haecceity Hi. This is a known issue. It’s why we’ve been working to fix in the 1.0 release. It is currently available in release candidate 2 on GitHub: https://make.xwp.co/2018/11/05/amp-plugin-release-v1-0-rc2/?amp

    Note that I linked you there to the AMP version of the page. Notice that it looks the same as the non-AMP version of the page: https://make.xwp.co/2018/11/05/amp-plugin-release-v1-0-rc2/ (This is running a child theme of Twenty Fifteen.)

    The goal of 1.0 and the new paired/native modes is to allow you to re-use your active theme’s templates and styles in AMP. The plugin includes built-in core theme support for AMP, and other themes will generally behave in AMP as if JS is disabled (since custom JS is not currently allowed in AMP). At this stage it is best geared toward site owners who have a small about of technical experience with theme/plugin development. Another example of a site that is using the new paired mode is my own, which runs a child theme of Twenty Seventeen: https://weston.ruter.net/?amp

    Bodhipaksa

    (@haecceity)

    Version 1.0 looks very impressive. I’m sure you understand, though, that any review I post can only reflect my experience of the plugin I used, and not future versions that I have no access to.

    Plugin Author Weston Ruter

    (@westonruter)

    Of course. But this is something you can try.

    Bodhipaksa

    (@haecceity)

    Understood. Thanks. I think I’ll wait until the final release, though.

    Bodhipaksa

    (@haecceity)

    Just a heads-up that I downloaded the version that was just released and my site started appearing with no styling. I disabled the plugin and my site’s back to normal again.

    Perhaps it’s a plugin conflict? I have Akismet, List category posts, SG Optimizer, Securi, Tweet Button for Quotes, and Wordfence installed.

    Plugin Author Weston Ruter

    (@westonruter)

    Your site appeared with no styling in paired mode or native mode?

    If you have a lot of CSS in your theme you should disable the admin bar on AMP page.

    If that still doesn’t fix the problem, then you may just have too much CSS in the site for the AMP plugin to convert into valid AMP. The plugin will excluded CSS once it gathers more than Max of 50KB. If you can leave up the paired mode of the site and send me the URL for a broken page then I can confirm.

    Bodhipaksa

    (@haecceity)

    Thanks for your offer of assistance.

    Initially I tried with native mode and the site was unstyled — except that the post content scrolled on top of the navigation, so there must have been some styling. The admin bar was disabled. I’m using a Twenty-Fifteen child theme, with only minor modifications.

    Having received your message I tried again with paired mode, and AMP pages were still unstyled.

    Here’s a link to a random amp page:
    https://www.realbuddhaquotes.com/i-do-not-dispute-with-the-world-rather-it-is-the-world-that-disputes-with-me/amp/

    I don’t want to leave the site this way for too long, so you you please let me know when you’ve taken a look?

    Bodhipaksa

    (@haecceity)

    I didn’t want to give visitors a bad experience, so I disabled the app. Let me know when you’re ready to take a look and I’ll enable it again.

    Plugin Author Weston Ruter

    (@westonruter)

    @haecceity Could you try enabling the paired mode and then take a screenshot of the page and grab the source code of the page as well? Then you can switch back to classic and share the results here so we can take a look.

    It’s promising that you’re using Twenty Fifteen, so the paired mode should work. For example, a child theme of Twenty Fifteen is running successfully with the plugin at https://make.xwp.co/?amp

    Bodhipaksa

    (@haecceity)

    Sure. I’ll do that right now.

    Bodhipaksa

    (@haecceity)

    Here’s a pastebin dump of the page code: https://pastebin.com/QV5jWW6K

    Bodhipaksa

    (@haecceity)

    Plugin Author Weston Ruter

    (@westonruter)

    That is unexpected. There should be a comment that appears above the style[amp-custom] element that lists out the sources for what is inside the stylesheet. You can see this from looking at the source code on https://make.xwp.co/?amp

    Also, the CSS appearing in the style[amp-custom] element is limited to just:

    @font-face{
        font-family:genericons;
        src:url("https://www.realbuddhaquotes.com/wp-content/themes/twentyfifteen/genericons/Genericons.eot")
    }
    @font-face{
        font-family:genericons;
        src:url("https://www.realbuddhaquotes.com/wp-content/themes/twentyfifteen/genericons/Genericons.woff") format("woff"),url("https://www.realbuddhaquotes.com/wp-content/themes/twentyfifteen/genericons/Genericons.ttf") format("truetype"),url("https://www.realbuddhaquotes.com/wp-content/themes/twentyfifteen/genericons/Genericons.svg#genericonsregular") format("svg");
        font-weight:400;
        font-style:normal
    }
    @media screen and (-webkit-min-device-pixel-ratio:0){
        @font-face{
            font-family:genericons;
            src:url("https://www.realbuddhaquotes.com/wp-content/themes/twentyfifteen/genericons/Genericons.svg#Genericons") format("svg")
        }
    }
    @media screen and (min-width: 59.6875em){
        #sidebar{
            position:sticky;
            top:-9vh;
            max-height:109vh;
            overflow-y:auto
        }
    }
    [class^=wp-block-] blockquote{
        border-color:#707070
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-c7efc2b{
        max-width:660px
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-7338e5c{
        display:none;
        text-align:right
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-131429e{
        max-width:650px
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-7d701bf{
        max-width:800px
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-0e69b90{
        max-width:847px
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-8794c93{
        max-width:849px
    }
    :root:not(#_):not(#_):not(#_):not(#_):not(#_) .amp-wp-d994343{
        max-width:500px
    }

    What other plugins do you have active on your site, if any?

    Bodhipaksa

    (@haecceity)

    The other plugins I have installed are Akismet, List category posts, SG Optimizer, Securi, Tweet Button for Quotes, and Wordfence.

    SG Optimizer is the most likely candidate for a plugin conflict. I’ll try disabling it and re-enabling AMP and then let you know how it turns out.

    Bodhipaksa

    (@haecceity)

    And that was it. With SG Optimizer disabled the AMP is working fine. I have it set to native mode. This particular site is fairly low traffic, so I’ll leave SG optimizer disabled.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Working great for me now!’ is closed to new replies.