Support » Plugin: WP YouTube Lyte » Sometimes the locally cached thumbs are not visible; only after CTRL + F5

  • Resolved Bark

    (@bark)


    Hi,

    It is not an end-of-the-world problem ๐Ÿ™‚ but I am just curious what sometimes causes the YouTube thumbs – that are cached locally – not to be displayed in a post. First, I thought it had smt to do with clearing my server cache (Siteground), for example after publishing a new post or saving an edited post, but I have not found a correlation between the two.

    When I press CTRL + F5 the thumbnail always appears and remains displayed for a while.

    So I am wondering if anyone has an idea?

    I am also using Autoptimize and Async JavaScript with the following settings:

    – Status Enabled
    – Method: Defer
    – jQuery: Defer
    – Autoptimize Status: Enabled
    – Autoptimize Method: Defer

    Furthermore, I have added script to my .htaccess file which enables GZIP compression and leverage browser caching.

    The YouTube thumbs are set to be cached locally.

    I am looking forward to an answer.

    Thanks and regards,
    Bark

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Afternoon Bark;
    The thumbnails are loaded late -after domcontentloaded- using JavaScript, so this might very well be due to JS-errors. Maybe check the console for errors?

    frank

    Good idea Frank! As soon as I have more info, I’ll get back to this forum.

    Bark

    Hi Frank,

    Well, this morning I came across a Javascript error that resulted in a YouTube Lyte thumb not being displayed:

    Screenschot of Javascript error

    After pressing CTRL + F5 it was gone and the thumb appeared.

    I hope you can say smt meaningful about it ๐Ÿ™‚

    Thanks and regards,
    Bark

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    maybe try adding lyte to AO’s comma-separated JS optimization exclusion list? that way even in case of such JS errors in the AO’ed JS-file, the thumbnails will load.

    Hi Frank,

    Thank you for helping me with this matter. I have added the two relevant Javascript files to the exclusion list: lyte-min.js, lyte.js

    Probably it will be solved now.

    Thanks and regards,
    Bark

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    hmm, except if you have “also aggregate inline JS” off you need to exclude lyte to ensure the inline JS isn’t aggregated.

    groeten uit Belgiรซ ๐Ÿ™‚
    frank

    Haha, Frank from Belgium. Well, this is Bark from the Netherlands ๐Ÿ™‚

    I already experienced the effect of what you wrote here above. The thumbs were displayed, but incompletely. So I added lyte to the exclusion list and voila problem solved!

    Thanks!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    happy it works!

    geniet van je weekend ๐Ÿ™‚
    frank

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Sometimes the locally cached thumbs are not visible; only after CTRL + F5’ is closed to new replies.