Support » Plugin: WP Recipe Maker » sometimes print url contains p query param

  • Resolved delicioushealthyhome

    (@delicioushealthyhome)


    I have noticed that sometimes when I click the Print button (from within the wprm_print page) the url sometimes changes to the recipe slug (ex: /cherry-nut-energy-bars), but sometimes it changes to the post query param (ex: /p?=611). Since this is the url that gets printed on the page, it would be nice if it was always the recipe slug. It seems to come and go (not always reproducible). I am using latest version of the plugin and wordpress (wp 5.6 and wprm 6.9.0). Any help?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Brecht

    (@brechtvds)

    What are your permalink settings set to on the Settings > Permalinks page?

    Thread Starter delicioushealthyhome

    (@delicioushealthyhome)

    It is set to “Post name”

    Plugin Author Brecht

    (@brechtvds)

    That should be fine. Can you give me a link to a recipe on your website?

    Feel free to email it to support@bootstrapped.ventures if you don’t want to share it publicly.

    Thread Starter delicioushealthyhome

    (@delicioushealthyhome)

    Hi Brecht,

    It’s no problem, this is the recipe I have been testing recently and seeing the issue:
    https://www.delicioushealthyhome.com/cherry-nut-energy-bars/

    Yesterday it was hit or miss, today it seems to be always using the query param format when I hit print…

    Plugin Author Brecht

    (@brechtvds)

    I see the issue. Not sure why that’s happening. I’ll have to do some testing on my end and will get back to you!

    Thread Starter delicioushealthyhome

    (@delicioushealthyhome)

    Great, thanks so much!

    Thread Starter delicioushealthyhome

    (@delicioushealthyhome)

    Hey Brecht,

    One thing I just noticed while poking around, from the WP Recipe Maker -> Manage -> Recipes table, the cherry nut energy bars recipe I have been testing with has a different parent name set, whose post id is the 611 I keep seeing. When I test the print functionality with a recipe that has the same parent name (ex: https://www.delicioushealthyhome.com/crumbly-fig-nut-energy-bars/) I see the print url change as I would expect.

    Additionally, the parent post that is set for the cherry bars is in draft state, and I had used the add existing recipe functionality to add the cherry bars recipe to that new post for some testing.

    So, perhaps there is something going on there…hopefully that makes some sense.

    Charlie

    Plugin Author Brecht

    (@brechtvds)

    Hi Charlie,

    Nice find. That’s actually the problem. When you click the print button it changes the URL to the URL of the parent post, which should be the post containing the recipe.

    Could you try editing what would be the correct parent post for that recipe and just saving it? When you save a post it looks for any recipes inside and associate itself as being the parent.

    Thread Starter delicioushealthyhome

    (@delicioushealthyhome)

    Hi Brecht,

    Confirmed that after publishing, the url contained the correct url when hitting the print button.

    Thanks for the quick/responsive support!

    Charlie

    Plugin Author Brecht

    (@brechtvds)

    Happy to hear that worked! Do let me know if you experience any other issues at all.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.