Support » Plugin: Print, PDF, Email by PrintFriendly » Something wrong it does nothing

  • Hi,

    I had installed and test printfriendly two year ago (3.5).
    I had made some changes and debug.
    Later I have inactivated it untill now, because it was tested as functionning and the site didn’t need it during development.

    I restart it now and it produces nothing, see further.
    So I have uninstalled the old version and installed the new one : 3.13.0 today.

    I get the same result with the new version :

    • The icon link are well displayed
    • When the user clicks on the icon this opens a new tab with the following url
      <same url for the post>/#
      which displays naturally with this empty hash (out of a query even empty…) the same post without any action by printfriendly.
    • The plugin doesn’t appears into the debugger (Chromium or chrome) : script not registered ?

    What’s happening ?

    Best regards

    Trebly

    Note : the parameters which are got in debug mode :
    Array
    (
    [button_type] => buttons/printfriendly-pdf-email-button.png
    [custom_button_icon] => https://cdn.printfriendly.com/icons/printfriendly-icon-md.png
    [custom_image] =>
    [custom_button_text] => custom-text
    [custom_text] => PrintFriendly
    [text_color] => #3AAA11
    [text_size] => 14
    [enable_css] => off
    [content_position] => left
    [content_placement] => after
    [margin_left] => 12
    [margin_right] => 12
    [margin_top] => 12
    [margin_bottom] => 12
    [logo] => favicon
    [image_url] =>
    [tagline] =>
    [click_to_delete] => 0
    [images-size] => full-size
    [image-style] => right
    [email] => 0
    [pdf] => 0
    [print] => 0
    [custom_css_url] =>
    [password_protected] => no
    [javascript] => yes
    [enable_google_analytics] => no
    [enable_error_reporting] => yes
    [pf_algo] => wp
    [db_version] => 16
    )

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Trebly

    (@trebly)

    Hi,

    This morning I tried again and then I got a display.

    I could verify that when you get this new url with the “#” as hash (without “?” query) if you click inside the viewport you can get the waited preview loaded from your site.
    I have too made an inspection of the html contents loaded and found scripts and styles (css) elements.

    My temporary conclusion is that you get the waited display of the print preview if your server answers immediately. But if this is not immediate (or very long the user can’t understand) the display is the precedent (of the user for which a print is requested).

    I think that a message should be displayed if this step is reached, and invite to repeat by a click into the viewport or more clearly a button “repeat call to print function”.

    I have not found a mean to change this because the user has not the control of this content.

    May be the cause of the phenomenon is that I have a very reactive line and server. Nevertheless such circumstances “print server doesn’t answer until now” should produce a display to guide the user.

    Best regards.

    Note : because I begin tests of printfriendly I have several question that I separate. It is not harassment, just a phase in which all questions come at same time.

    • This reply was modified 3 years, 1 month ago by Trebly.
    Plugin Author Print & PDF by PrintFriendly

    (@printfriendly)

    If you get a Pro subscription it will avoid this problem all together, as it works clientside.

    You can get at https://www.printfriendly.com/button/pro

    Else, please send the URL to a specific page we can observe the issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Something wrong it does nothing’ is closed to new replies.