Support » Plugin: Facebook for WooCommerce » Something went wrong when connecting to Facebook!

  • Resolved jaybee13200

    (@jaybee13200)


    Hi
    As all users who comments, i’ve the same problem everything works but at the final step when i click on ok i’ve message
    “Something went wrong when connecting to Facebook!”
    I’ve delete all the shop in facebook businness, add a new pixel, change the name in wp-admin/options.php, check the box manage my businness
    Nothing works
    any idea ??

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Marcus, SkyVerge Support

    (@marcusskyverge)

    Hi @jaybee13200,

    Thanks for reaching out. Great work narrowing down the possible issues! Happy to help you with this.

    Unfortunately, the “Something went wrong” error doesn’t tell us too much about what the issue might be. To help us out, we have a code snippet that I can share that will give us some better error messaging on that screen.

    Here is the snippet:
    add_filter( 'wc_facebook_connection_proxy_url', function() { return 'https://wc-connect-test.skyverge.com/auth/facebook/';} );

    If you’re not sure how to add this snippet to your site, we have a blog post that should help out here. I personally prefer the free Code Snippets plugin for this.

    Would you please add this to your site and try to connect again? I look forward to seeing what the error message gives you this time.

    Thanks,
    Marcus

    Hello,

    I am also having exactly the same problem.

    I get the following message:

    Something went wrong when connecting to Facebook!
    Please try again – Could not create On Behalf Of relationship – POST https://graph.facebook.com/v7.0/***************/managed_businesses?existing_client_business_id=1787215744768832&access_token=EAAGvQJc4NAQBAF0657pFZA2M1oJUtGyllU8ZAVPrOfxMtpjMwAk6H8JiHZCmowKbqscbtXtbpZBzs1svY8F5JWXcqQdDMUo542T7bFMXVR5U3BaphjvH9n7aekktTL0c0X5olD063Cxh11TLKHz1hdk0qJ0qrQMk7MxgeZCGd4gZDZD resulted in a 403 Forbidden response: {“error”:{“message”:”(#200) Requires business_management permission to manage the object”,”type”:”OAuthException”,”code”:200,”fbtrace_id”:”AUIZJt6sY23p28ru3mhmO7k”}}

    Please help?

    Plugin Support Marcus, SkyVerge Support

    (@marcusskyverge)

    Hey @bootsnbourbon,

    Thank you for reaching out here. While the “Something went wrong” error is a bit of a catch-all and doesn’t necessarily mean that you’re having the same issue, I think I see what you are experiencing.

    When stepping through the connection setup process, you should see a screen with a few on/off toggles. You’ll need to make sure that the “Manage business” toggle is ON. Facebook recently switched the default to be OFF.

    Would you please try to connect again, making sure to toggle ON the “Manage business” setting?

    Thanks,
    Marcus

    Hi Marcus,

    I’ve got the plugin connected now, but I still have issues on the Facebook end..

    Even though my page is a business page, and I am the admin of this page, when I try and set up my shop tab through Facebook’s commerce manager, I get the following messages for my Facebook pages: “this business manager account can’t be selected because it doesn’t meet our requirements for shops.”

    How do I fix this?

    Chris

    Plugin Support Marcus, SkyVerge Support

    (@marcusskyverge)

    Hey @bootsnbourbon,

    Thank you for the update. I’m happy to hear that you were able to successfully connect to your account.

    When it comes to setting up the shop itself, I’m afraid you’ll need to reach out to Facebook directly to see if they can share which requirements are not being met. I was able to find this article that might give you some insight:
    https://www.facebook.com/business/help/2347002662267537

    To reach out to them directly, I would recommend using this help link:
    https://www.facebook.com/help/contact/552096935652452

    Would you please let me know if this is helpful and if there’s anything else I can help with?

    Thanks,
    Marcus

    Hello Marcus,

    Thank you, I have got the Facebook shop setup now.

    I do need further help however. Only my merchandise products show up, which are printify products. My affiliate products are not syncing properly. Please can you help with this?

    Kind Regards,
    Chris

    Plugin Support Marcus, SkyVerge Support

    (@marcusskyverge)

    Hi Chris,

    Thank you for your reply. I’m happy to hear that you are now connected!

    For your affiliate products, would you please tell me a little bit more about how they are set up? Are they set as “virtual” products? Can I get you to please tell me which Facebook sync status they are set to in your site?

    Thanks,
    Marcus

    Hi Marcus,

    Do you have a private email address? I can send you temporary login credentials and you can check yourself?

    Chris

    Plugin Support Marcus, SkyVerge Support

    (@marcusskyverge)

    Hi Chris,

    Thank you for your reply. I’d be happy to take a look. I have an email address that is specific to this conversation, so I’ll leave it in a Quickforget link so you can grab it, but that way it won’t remain here for others to jump in on 😉

    Here is the link to the email address:
    https://quickforget.com/s/3b2461a4333daf804f5d65f5ccab94ddc504c08b450f076a

    Note: I’m going to go ahead and close this topic so we can continue there.

    Thanks,
    Marcus

    Hey Marcus,

    I just tried using the link you sent me, but it says “Sorry, I’ve already forgotten that secret,”

    Can you send it again please?

    Regards,
    Chris

    Plugin Support Marcus, SkyVerge Support

    (@marcusskyverge)

    Hey @bootsnbourbon,

    Well, shoot. Thanks for letting me know. I’ve upped the view count and time here:
    https://quickforget.com/s/6d8fc8af39577336e63a3905390ab58775bbbf2629c0f71e

    Would you please try again and see if it works this time?

    Thanks,
    Marcus

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Something went wrong when connecting to Facebook!’ is closed to new replies.