Support » Plugin: Facebook for WooCommerce » Something went wrong when connecting to Facebook!

  • Resolved rcveen

    (@rcveen)


    I have the same issue here.

    I was able to edit all pages..
    but the last page I get;

    Something went wrong when connecting to Facebook!
    Please try again.

    wp 5.5.3
    plugin facebook for woocommerce 2.1.4

Viewing 7 replies - 1 through 7 (of 7 total)
  • Io esattamente come te…

    Thread Starter rcveen

    (@rcveen)

    from another thread i did the following:

    add plugin : Code Snippets
    activate
    settings
    add new snippit

    paste the following:

    add_filter( ‘wc_facebook_connection_proxy_url’, function() { return ‘https://wc-connect-test.skyverge.com/auth/facebook/’;} );

    that resulted in a OATH error..
    when connecting to facebook..

    now I have to find what autorisation i need ….

    damn

    Thread Starter rcveen

    (@rcveen)

    Something went wrong when connecting to Facebook!
    Please try again – Could not create On Behalf Of relationship – POST https://graph.facebook.com/v7.0/***************/managed_businesses?existing_client_business_id=YYYYY&access_token=XXXXX resulted in a 403 Forbidden response: {“error”:{“message”:”(#200) Requires business_management permission to manage the object”,”type”:”OAuthException”,”code”:200,”fbtrace_id”:”ATnZtE1jNb0PU9cP8Hgn61F”}}

    I replaced the credentials.. 🙂

    where should I adjust the credentials.. which credentials?

    what do I need to change?

    Plugin Support Erica – SkyVerge Support

    (@ericaskyverge)

    Hi @rcveen!

    Thanks for reaching out to us about Facebook for WooCommerce! I’m sorry to hear that the plugin isn’t working as expected. I am happy to help out here.

    Thank you for using the snippet and providing the error message. It looks like this a business management permissions error. Facebook recently updated their settings to toggle “Manage your business” permission to Off by default. This needs to be set to On. Can you please go to your Facebook settings and select Business Integrations > WooCommerce Extension V2 and check that the Manage your business setting is toggled to the On position?

    https://cloud.skyver.ge/o0umOywP

    Once this is toggled to On, can you please try to connect again and let me know if this resolves the issue for you?

    Best,
    Erica

    Plugin Support Erica – SkyVerge Support

    (@ericaskyverge)

    Hey @rcveen,

    It has been a while since we heard from you, so I’m going to mark this topic as resolved. If you’re still experiencing issues please take a look at our documentation for more information and create a new thread if you have further questions.

    Thanks,
    Erica

    Thread Starter rcveen

    (@rcveen)

    Hi erica,

    I still have an issue connecting to Facebook ..
    It looks like the created id doesn’t have sufficient authorization.

    On another site I removed that id and then started from scratch.. that resolved it.

    but I did;t succeed yet on my primary site

    Plugin Support Erica – SkyVerge Support

    (@ericaskyverge)

    Hi @rcveen!

    Would it be possible for you to start a new thread? As this is a slightly different issue, we would like all users to be able to easily find the thread if they search for the same
    problem.

    Best,
    Erica

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.