Support » Plugin: Redirection » Something went wrong

  • Resolved richard

    (@rich_smc)


    Hi there,

    Odd one, looks like theres an error, i get this:

    Something went wrong 🙁

    Your server returned a 403 Forbidden error which may indicate the request was blocked. Are you using a firewall or a security plugin like mod_security?

    If you are unable to get anything working then Redirection may have difficulty communicating with your server. You can try manually changing this setting:
    REST API:

    Take a look at the plugin status. It may be able to identify and “magic fix” the problem.
    Redirection is unable to talk to your REST API. If you have disabled it then you will need to enable it.
    Security software may be blocking Redirection. You will need to configure this to allow REST API requests.
    Caching software, in particular Cloudflare, can cache the wrong thing. Try clearing all your caches.
    Please temporarily disable other plugins! This fixes so many problems.

    Important details

    Include these details in your report along with a description of what you were doing.

    Plugin: 4.1.1
    WordPress: 5.1.1 (single)
    PHP: 7.2.14
    Browser: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
    JavaScript: https://www.[hidden].com/wp-content/plugins/redirection/redirection.js
    REST API: https://www.[hidden].com/wp-json/

    Error: JSON.parse: unexpected character at line 1 column 2 of the JSON data
    Action: redirection/v1/plugin/database/ POST
    Params: {}
    Code: 403 Forbidden
    Raw: <!DOCTYPE html>
    <html style=”height: 100%;”>
    <meta charset=”UTF-8″>
    <head><title>403 Access Forbidden</title></head>
    <body style=”height: 100%;”>
    <div style=”display: flex; align-items: center; justify-content: center; height: 70%;”>
    <div style=”background-color: #eee; width: 70%; border: solid 3px #ddd; padding: 1.5em 3em 3em 3em; font-family: Arial, Helvetica, sans-serif;”>
    <div style=”display: table-row;”>
    <div style=”display: table-cell; font-size: 150px; color: red; vertical-align: middle; padding-right: 50px;”>

    </div>
    <div style=”display: table-cell; vertical-align: middle;”>
    <h1>We’re sorry, you are not allowed to proceed</h1>
    <p>Our server stopped processing your request. Your request looks suspicious or similar to automated
    requests from spam posting software.</p>
    <p>If you believe you should be able to perform this request, please let us know.</p>
    </div>
    </div>
    </div>
    </div>
    </body>
    </html>

    I have 4 websites, generally the same plugin with re-direction, the other 3 were fine. Ive cleared the caching (cloudflare) but i havent gone any further than that, any ideas would be great? thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author John Godley

    (@johnny5)

    Your REST API is likely being blocked by a security plugin. Please see https://redirection.me/support/problems/rest-api/

    thank you john.

    Must be the plugin i have – WP total cache (and Cloudflare).

    Currently i have it set at –

    REST API
    Don’t cache (Ticked)
    Cache (Upgrade now to enable) (Not ticked)
    Disable REST API (Controls WordPress REST API functionality.) (Not ticked)

    Although my other sites all have the same settings, but dont seem to have any issues. Can i alter this? I dont want to change too much for WP Total cache/Cloudflare, took me some time for that to be set working correctly…..

    Thank you

    Plugin Author John Godley

    (@johnny5)

    Do you have any security plugins?

    Whats the advantage of using the rest api? Isn’t it better to not expose the rest api if not necessary and accomplish everything in PHP?

    Plugin Author John Godley

    (@johnny5)

    @jiggaman everything is in PHP, accessible through the REST API

    I have WP Cerber Security plugin……..

    Plugin Author John Godley

    (@johnny5)

    @rich_smc ok, it’s likely that WP Cerber is blocking your REST API. You should be able to configure it not to do this.

    Yes, sorted it out – WP Cerber Security; Hardening WordPress; Disable REST API (un-click) cheers

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Something went wrong’ is closed to new replies.