Loco Translate
Something strange saving path (2 posts)

  1. digiblogger
    Posted 1 year ago #

    Hello there,

    I tried to translate some plugins (create new language (German) de_DE ) an start translating.

    First of all: I can not save more than one phrase at the same time. Chaning the row deleted the translation. Tested on 4 different themes without any other plugins.

    But when I click save, it says "no permission..." I checked the "languages" folder inside wp-content and set it to chmod 777.
    Still: "no permission".
    I checked the plugin directory (wp-content/plugins/myplugin/) and found another languages folder with a folder named "plugin-de_DE.po" inside. I deleted this folder and set plugin/myplugin/languages to chmod 777.

    Now I can save my translation successfully, but it does not take effect.

    I copied the po/mo to wp-content/languages - no effect
    I renamed the po/mo in wp-content/plugins/myplugin/languages to de_DE.po and de_DE.mo (instead of "myplugin-de_DE.po" and "myplugin-de_DE.mo") - no effect.

    I checked wp-config.php and it says:

    define('WPLANG', 'de_DE');

    So... whats the mistake?


  2. timwhitlock
    Plugin Author

    Posted 1 year ago #

    Re your first issue about saving more than phrase:
    - What browser are you using?

    Re your second issue about language file locations:
    - Loco will try to save the files in the most likely location you intend, based on the folders you have made writable and will try to put the PO files with the POT file if there is one and its folder is writable. Why your plugin translations are not showing up may be to do with how your plugin is initialising the text domain. What WordPress functions are you using to do this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Loco Translate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.