Support » Plugin: Comments - wpDiscuz » Something gone wrong with 4.1.0 update

  • Resolved hothbricks

    (@hothbricks)



    Looks like something is wrong with the last version :

    By default the list of comments is not displayed at all, you need to sort them once (older/recent) to make then appear.

    Back to previous version, everything is fine again…

    More : Narrowed the issue to the “Lazy load comments on scrolling” option. When activated, comments do not appear at all, other two options are working fine (“[Load more] Button” and “[Load rest of all comments] Button”

    More 2 : The issue comes from the Lazy loading : The scrollbar must be at the bottom end of the window to start loading comments even for the first batch that normally should appear straight on.

    • This topic was modified 1 year ago by  hothbricks.
    • This topic was modified 1 year ago by  hothbricks.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author AdvancedCoding

    (@advancedcoding)

    Hi hothbricks,

    The logic of “lazy load” has been changed in 4.1.0 version, so the comments will load after scrollbar position reaches 90% of window height which makes page load more quick.

    hothbricks

    (@hothbricks)

    Well, I understand this, but why the first batch of comments is not displayed at all until scrolling ? First comments should be displayed, whatever the position of the scrollbar, then lazy load should start acting when the scrollbar goes down to 90% of the window.

    marcinglivice

    (@marcinglivice)

    Unfortunately, comments load slower. Now we have to wait about a second before they show up 🙁

    matttozerstory

    (@matttozerstory)

    Same just updated know having to restore from backup as major issue with plugin. Fatal Error.I have a screen shot.

    Plugin Author gVectors Team

    (@gvectors-team)

    Hi hothbricks

    First comments should be displayed, whatever the position of the scrollbar, then lazy load should start acting when the scrollbar goes down to 90% of the window.

    We’ve added and option to choose the first comments loading logic. We’re preparing v4.1.1 version, it’ll be released very soon.

    Plugin Author gVectors Team

    (@gvectors-team)

    Hi marcinglivice,

    Unfortunately, comments load slower. Now we have to wait about a second before they show up 🙁

    Please delete all caches and leave some URL to allow us check it.

    hothbricks

    (@hothbricks)

    We’ve added and option to choose the first comments loading logic. We’re preparing v4.1.1 version, it’ll be released very soon.

    Exactly what’s needed here. thanks for that.

    Plugin Author gVectors Team

    (@gvectors-team)

    Hi matttozerstory

    Same just updated know having to restore from backup as major issue with plugin. Fatal Error.I have a screen shot.

    What do you mean saying “Same”? Nobody here reported about “Fatal Error”. wpDiscuz is already updated on 3,000 websites within last 24 hours. We’ve not got other report about Fatal Error. This is a site specific problem for sure. I think the update was incomplete.
    Please never downgrade plugin. Just deactivate, delete and install it again. Then delete all caches and purge CDN. I think there should not be such problem again. Also please leave the Fatal Error message text here. The phrase “Fatal Ererror” says nothing, you should provide more information or the whole error message to allow us help you. BTW there is no any screenshot in your post.

    hothbricks

    (@hothbricks)

    We’ve added and option to choose the first comments loading logic. We’re preparing v4.1.1 version, it’ll be released very soon.

    I see you just pushed a new version, but I cannot seem to find this option anywhere. Any help about where it’s located ? Thanks

    • This reply was modified 1 year ago by  hothbricks.
    Plugin Author AdvancedCoding

    (@advancedcoding)

    Hi hothbricks, Please see the screenshot below.

    2017-11-16_1636

    marcinglivice

    (@marcinglivice)

    Now everything works fine. Thank you

    hothbricks

    (@hothbricks)

    @AdvancecCoding : Thanks, did not figure out you need to activate Lazy load for this option ot show up. My bad. Good job.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Something gone wrong with 4.1.0 update’ is closed to new replies.