Support » Plugin: PHP/MySQL CPU performance statistics » Something definitely isn't right with these results

  • Resolved Robert

    (@robg48)


    Hey there,
    Just thought I’d paste these results below to see if anyone has thoughts on why they seem to not be even in the ball park 😉

    I’m running an Ubuntu 14.04VM with 4 core, 8 gb ram, LAMP, 8gb swapfile, compression all around and the database is local with only 4 Mb of data.

    Oh – and the first clue that there is a problem is I have my memory limit set at 2048mb – not 256mb as is reported. Doing speed tests from external systems the average load time is 1.7s and doing a search in the database directly is immediate.

    Thanks!

    PHP host information Linux jlghitlink 3.16.0-31-generic #41~14.04.1-Ubuntu SMP Wed Feb 11 19:30:13 UTC 2015 x86_64
    PHP version 5.5.9-1ubuntu4.7
    PHP memory limit 256M
    PHP post_max_size 512M
    PHP upload_max_size 256M
    PHP max_execution_time -1 seconds
    Webserver Apache/2.4.7 (Ubuntu)
    Loaded webserver modules core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_mime prefork mod_negotiation mod_php5 mod_rewrite mod_setenvif mod_status
    Platform Linux
    Gateway interface CGI/1.1
    Path to files /var/www/html/wp-admin
    MySQL version 5.5.41-0ubuntu0.14.04.1
    Server load now: 0.36
    Server load avg. 5 minutes: 0.32
    Server load avg. 15 minutes: 0.83
    MySQL test:
    Time to perform: Query test (200 times) :135.64 seconds (1/sec)
    Time to perform: select BENCHMARK(500000000, EXTRACT(YEAR FROM NOW())) : 18.89 seconds
    Time to perform: select BENCHMARK(10000000,ENCODE(‘hello’,’goodbye’)) : 5.95 seconds
    Time to perform: select BENCHMARK(25000000,1+1*2); : 2.23 seconds
    Total time (all MySQL tests) :162.71 seconds
    PHP test:
    Time to perform: Math test : 1.25 seconds
    Time to perform: StringManipulation test : 2.83 seconds
    Time to perform: test Loop test : 1.54 seconds
    Time to perform: test IfElse : 2.50 seconds
    Total time (all PHP tests) : 8.12 seconds
    Network test:
    Network test 1: Fetch data from nearest google CDN point : 26.22 Mbps
    Network test 2: Fetch data from our servers in Europe at http://www.mywebtonet.com : 3.15 Mbps
    All tests:
    Total time (all MySQL + PHP tests) :170.83 seconds

    https://wordpress.org/plugins/mywebtonet-performancestats/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mywebtonet

    (@mywebtonet)

    Hi

    The results are accurate enough as they’re actually just simple tests performed against your PHP and your MySQL server. The phpmemory limit you are referring to are fetched from PHP itself with a builtin PHP command which shouldn’t report incorrectly, if the figure appears incorrect compared to your php.ini, your PHP installation might use another php.ini file or your PHP might not report correctly. You’re using a very old PHP 5.5 version, we can definately recommend that you get it upgraded.

    Looking at the figures, we guess you’re using a Q6/9XXX Intel CPU or a 3-4 year old AMD CPU.

    If we do the test

    select BENCHMARK(500000000, EXTRACT(YEAR FROM NOW()))

    on our MySQL servers we allocate to our hosting customers, our servers does this test in 3.3 to 4 seconds, your server reports 18 seconds. You can try the test directly on your MySQL server via your PHPMyAdmin interface.

    So the figures are definately correct as they are (you can look in the source code how all these tests are done).

    You do however have a serious problem with your MySQL configuration, the test we do, and where your server fails (135.64 seconds) can be due to:

    buffer settings in your my.cnf file
    slow write performance on your disk system
    not enough memory allocated to MySQL

    Keep in mind that you website’s load time of 1.7 seconds is probably just doing reads from your MySQL, our test does table creating, insert to table and delete tables, 200 times.

    Thats all for now 🙂

    Plugin Author mywebtonet

    (@mywebtonet)

    Hi again

    Just made a minor update to the plugin, if you delete the plugin and install it again from the repository and run it again you can see a new line showing the location of the php.ini file used, might get you on the right path in regards to the php_memory_limit.

    Rgds, MyWebToNet

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Something definitely isn't right with these results’ is closed to new replies.