Support » Plugin: Falang multilanguage for WordPress » Some words in translated (Nepali) Language are appearing in weird English words

  • Resolved eSabthok

    (@esabthok)


    My site original site is http://www.esabthok.com and had made English languaage as default language which redirects to http://www.esabthok.com/english/ and choose Nepali language as translated one which redirects to http://www.esabthok.com/nepali/.

    All looks fine but as far now I have noticed 2 words (किनभने and बारे) in translated language are being displaying as ’bout and ’cause in every single post.

    This change in 2 words appear all over the site. looks like swapping these words with another one.

    I have attached screenshots of the original posts and translated posts written in wordpress editor as well as how it appear in front end. This is the Screenshot

    And for testing I had put one post on first in home page, Please have a look on it by changing the language. This is my site address.

    Please let me know how to get rid of this issue.

    • This topic was modified 3 months, 1 week ago by eSabthok.
    • This topic was modified 3 months, 1 week ago by Yui.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • Thread Starter eSabthok

    (@esabthok)

    Hi, looks like my support questions are nit being visible to the plugin teams. Could some one try to help me please. I am interested in paid version but want to be sure all will works normally without any issues.

    Currently I am with other translations plugin in paid version but getting to much errors so planning to move to falang once this issue will be resolved.

    I can provide the admin details of the site if needed for bug fixing. thank you

    Plugin Author sbouey

    (@sbouey)

    Please , look how many support thread to your site i have responded. i have passed probably several hours on all your’s problems.

    most of the time you don’t give me any informations about the problem, only the link of the site is not enought , screen capture of the backend where you configure this message is necessary.

    You use a free plugin , i make support on the wordpress.org site but i make first support to my customers of course. i respond generally in a few hours not always…

    Best regards,
    Stéphane

    Plugin Author sbouey

    (@sbouey)

    And to complete my previous post , this time you give me more info

    Nepali is not an easy language to make support for me.

    your default is english on your screenshot but when i see the site it’s seem the default language is modified , normally it’s not possible

    Stéphane

    Thread Starter eSabthok

    (@esabthok)

    thank you for the reply. I acknowledge that I created many threads its because I have encountered many issues and are different to each other. And thought it might help others as all have different issues topics. Also I can choose resolve in individual topics when issues are fixed. Sorry for that.

    My default site is English but in cpanel I had redirected esabthok.com to esabthok.com/nepali. As in previous thread you mention there is no option in this plugin to choose the redirection of root domain in desired language. I can disable it if it is not allowed.

    Could you please investigate this problem and let me know jow to fix this issue. Thank you. sorry for inconvenience.

    Plugin Author sbouey

    (@sbouey)

    Hi,

    You says your site is done in English (in wordpress) but when i visit your site i see a lot of nepali text , it’s not normal

    The normal way is to have your site working in your default language (english) and translate step by step in other language (neapli)

    Best regards,
    Stéphane
    [Signature removed by moderator per forum guidelines.]

    • This reply was modified 3 months ago by Yui.
    • This reply was modified 3 months ago by Yui. Reason: signature link dropped
    Thread Starter eSabthok

    (@esabthok)

    its because I was using other translation plugin before and I made Nepali default amd english as translated for that plugin.

    Thats why default posts are in Nepali. I am testing this plugin and saw the error mentioned in support question. Once this is resolved, I will put english language in default and Nepali in translated one. I don’t have too much posts in this site, So I can do it manually.

    So I had created a testing posts and wrote those words only which are encountering issues.

    But I had selected English as default language and Nepali as translated language in this plugin and in wordpress setting as well.

    Plugin Author sbouey

    (@sbouey)

    Ok it can explain a lot of problem if you mix translation plugin
    i have see your post on TranslatePress

    Perhaps the problem of this thread is due to some info from other plugins.

    Before using falang be sure your site work completly in the default language (english) with no Nepali data.
    Even if you have a redirect in htacess when you go back to english all need to be write in english

    the “readmore” problem is a Falang not supported feature. the support will be add partially in the next release with a filter

    Stéphane
    faboba.com

    Thread Starter eSabthok

    (@esabthok)

    Actually I havent mixed the translation plugins, I have disabled the translatepress plugin and only activate Falang. I believe this issues is not because of mixed language as I have seen these when my post was in single langauge as well.

    I understand about English as default I will write every thing in English as mixed language does not looks good as well. At the moment I cant change all the posts in English because I dont know if this issue will be solved, if not I have to go with out translation using Nepali language only, because its hard to read with those words (’bout & ’cause) which give no sense in between the sentences.

    I tried almost all plugins and had faces similar issues, And When I was with WPML (paid version), their support team said the only solution is to change they suggest to change language locale from ne_NP to ne only. No need to change for English language.

    But due to some reason I have to move to translatepress (Paid version) and again I find some missing feature there like cant hide default post or have to translate all string even if I dont need to, cant skip some string or hide in translated one etc.

    When I saw falang and gave a try every thing is perfect, except some minor missing features like floating language switcher, changing redirection of root domain to any language as per necessary and editing language locale.

    I can go with out language switcher and root domain redirection hoping it will be available in coming future or if not thats fine. But with our changing language locale its impossible to use multilingual site for me in current situation.

    Because this is what is happening to my Nepali site. for eg, I have written. I go to home in post but appear as I حاخا.دف to home.

    Original post: I go to home
    Appeared post: I حاخا.دف to home

    = word go is replaced by senseless word حاخادف every where.

    This word gives no sense to sentences. and this حاخادف is not any translation of the replaced words, it just appeared from nowhere, its weird.

    So, please could you your best to solve this issue? Till now only way to fix is changing language locale in wordpress plugin setting. I don’t have any idea about other way unless you find it out with your team.

    Plugin Author sbouey

    (@sbouey)

    Hi,

    You say you have installed 3 multilanguage languages plugins on the same site.

    now you have word repalced everywhere
    = word go is replaced by senseless word حاخادف every where.

    falang don’t do this try to find why you have this

    I thinks some issuee you have are because your site is not clean. Falang don’t change the data structure all translation are stored in meta.

    When you disabled Falang and regerate permalink all should work in the default langauge.

    I can only make support on clean site and it’s not the case here. make your site working on nepali or english without Falang published and after that it’s possible to make support.

    Stéphane
    [Signature removed by moderator per forum guidelines.]

    • This reply was modified 3 months ago by Yui.
    • This reply was modified 3 months ago by Yui. Reason: signature link dropped
    Thread Starter eSabthok

    (@esabthok)

    Hi, I did not mean to say go is replaced by حاخادف everywhere. I just gave an example how it looks in Nepali language as you don’t understand Nepali. The replaced word don’t give any sense.

    If you want I can create another clean site for you for testing purpose with falang plugin installed only. And see what happens.

    Thread Starter eSabthok

    (@esabthok)

    Hi I have just installed fresh wordpress in new domain MirrorFact its all fresh just created couple of minutes ago with only 1 plugin (Falang) in total, Still I am having same issue. Please have a look on it, thanks

    Here is the screenshot of the issue. There is only one post and you can swap between the languages as well. I had added language switcher in the top for easy.

    Plugin Author sbouey

    (@sbouey)

    Hi,

    This is a good think because now i’m sure it’s a Falang problem somewhere

    you install a new wordpress englis site
    wit a free template from moral themes

    what is the moral themes name to make the same install ?
    you install falang and after that you install the nepali language in Falang

    you translate the hello world page

    ps : slug translation in utf-8 is not yet supported.

    Stéphane

    Thread Starter eSabthok

    (@esabthok)

    I did not get it. Is there any solution? Is the problem on Falang in this case?

    Plugin Author sbouey

    (@sbouey)

    yes i have to look what’s wrong , i have to make the same site , you didn’t answer to my previous question about the template you use
    and all the step to build the site

    i can’t look before monday

    Stéphane

    Thread Starter eSabthok

    (@esabthok)

    yes I install a new wordpress and default language is English.

    I have use free “Moral Magazine” from moral theme.

    After that I installed falang and make Nepali language as translated version.

    And I translate the Hello post into Nepali language.

    Thank you

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.