Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support alexrollin

    (@alexrollin)

    Hello,

    by default GD strips HTML from textarea fields.

    If you want to allow more HTML visit the textarea custom field settings and enable the advanced editor under the advanced settings.

    If you need more help please put in a ticket in your site dashboard under

    WP Admin – AyeCode – Help Widget (Blue button)

    • This reply was modified 1 year, 1 month ago by alexrollin.
    Thread Starter riddlediddle

    (@riddlediddle)

    Thanks for the reply.
    Are these settings available with the free version?
    Can’t find the advanced editor option.

    Thread Starter riddlediddle

    (@riddlediddle)

    Even if i create a new post, the text is not bolded:
    https://bikepark-check.de/2021/08/14/fridays-for-freeride/
    Is this normal?

    Thread Starter riddlediddle

    (@riddlediddle)

    After many tests, i realised the problem is not the plugin, it’s the theme directory starter.
    Any tips to solve this?

    • This reply was modified 1 year, 1 month ago by riddlediddle.
    Plugin Support alexrollin

    (@alexrollin)

    Hello,

    Step 4 on this doc shows the advanced settings in the custom field options.

    https://docs.wpgeodirectory.com/article/303-how-to-add-a-custom-field-to-cpt

    Thread Starter riddlediddle

    (@riddlediddle)

    These options are not available for me.
    But that’s not the problem. The problem is in the theme “directory starter” in the header.php.
    Something strips all the html tags (even in postings an own pages) in these file.

    It has something to do with the wp_head() tag, but i don’t know what’s wrong.

    <!DOCTYPE html>
    <html <?php language_attributes(); ?> class="no-js bsui">
    <head>
    	<meta charset="<?php bloginfo( 'charset' ); ?>">
    	<meta name="viewport" content="width=device-width">
    	<link rel="profile" href="http://gmpg.org/xfn/11">
    	<link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>">
    	<?php wp_head(); ?>
    </head>
    
    <body <?php body_class(); ?>>
    <?php
    if(function_exists('wp_body_open')){wp_body_open();}
    do_action('dt_before_header');
    
    $enable_header_top = esc_attr(get_theme_mod('dt_enable_header_top', DT_ENABLE_HEADER_TOP));
    if ($enable_header_top == '1') {
    	$extra_class = 'dt-header-top-enabled';
    } else {
    	$extra_class = '';
    }
    ?>
    <header id="site-header" class="site-header <?php echo apply_filters('dt_header_extra_class', $extra_class); ?> <?php echo esc_attr( get_theme_mod('dt_header_shadow', DT_HEADER_SHADOW) ); ?>" role="banner" style="<?php echo dt_header_image(); ?>">
    	<nav class="navbar navbar-expand-lg navbar-dark navbar-multi-sub-menus  <?php if(get_theme_mod('dt_container_full', DT_CONTAINER_FULL)){echo 'container-fluid';}else{ echo "container";}?>" style="z-index: 1025;">
    		<?php
    		/**
    		 * This action is called before the site logo wrapper.
    		 *
    		 * @since 1.0.2
    		 */
    		do_action('dt_before_site_logo');?>
    
    		<?php if ( get_theme_mod( 'logo', false ) ) : ?>
    			<div class='navbar-brand'>
    				<a href='<?php echo esc_url( home_url( '/' ) ); ?>' title='<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>' rel='home'><img src='<?php echo esc_url( get_theme_mod( 'logo', false ) ); ?>' alt='<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>'></a>
    			</div>
    		<?php else : ?>
    			<?php
    			if ( display_header_text() )
    				$style = ' style="color:#' . get_header_textcolor() . ' !important;"';
    			else
    				$style = ' style="display:none;"';
    
    			if ( display_header_text() ) : ?>
    				<?php
    				$desc = get_bloginfo( 'description', 'display' );
    				$class = '';
    				if (!$desc) {
    					$class = 'site-title-no-desc';
    				}
    				?>
    				<hgroup>
    					<h1 class='site-title h2 mb-0  <?php echo $class; ?>'>
    						<a class="navbar-brand" <?php echo $style; ?> href='<?php echo esc_url( home_url( '/' ) ); ?>' title='<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>' rel='home'><?php bloginfo( 'name' ); ?></a>
    					</h1>
    					<?php
    					if ($enable_header_top != '1') { ?>
    						<div class="site-description h6">
    							<a <?php echo $style; ?> href='<?php echo esc_url( home_url( '/' ) ); ?>' title='<?php echo esc_attr( $desc ); ?>' rel='home'><?php echo $desc; ?></a>
    						</div>
    					<?php } ?>
    				</hgroup>
    			<?php endif; ?>
    		<?php endif; ?>
    		<button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#primary-nav" aria-controls="primary-nav" aria-expanded="false" aria-label="Toggle navigation">
    			<span class="navbar-toggler-icon"></span>
    		</button>
    
    		<div class="collapse navbar-collapse " id="primary-nav">
    			<?php if ( has_nav_menu( 'primary-menu' ) ) {
    					wp_nav_menu( array(
    						'container'      => false,
    						'theme_location' => 'primary-menu',
    						'menu_class' => 'navbar-nav ml-auto text-nowrap flex-wrap'
    					) );
    				}
    			?>
    		</div>
    	</nav>
    </header>
    <?php do_action('dt_after_header'); ?>
    Thread Starter riddlediddle

    (@riddlediddle)

    I edited the body at Design -> Customizer -> Body -> Typografie and deleted all fonts, now the bolded text is working.
    if i add some font, the bolded text shows up not bolded.

    Now i found the problem, but can’t resolve it:
    in lib/styles.php there is the code font-family: <?php echo sanitize_text_field(get_theme_mod('dt_font_family', DT_FONT_FAMILY)); under the 3.4.1 – Font Family section.
    If i remove this line, everything is ok, except there is only the ugly standard font.

    How do i can resolve that?

    • This reply was modified 1 year, 1 month ago by riddlediddle.
    • This reply was modified 1 year, 1 month ago by riddlediddle.
    • This reply was modified 1 year, 1 month ago by riddlediddle.
    Thread Starter riddlediddle

    (@riddlediddle)

    If i add ANY font-family, doesn’t matter where, the theme strips the html from the whole webpage.

    I really hope there is a solution.

    Plugin Author Paolo

    (@paoltaia)

    Hi,

    developers alerted, they’ll let you know ASAP.

    Thanks for your patience,

    Thread Starter riddlediddle

    (@riddlediddle)

    thanks for the help so far 🙂

    Hi @riddlediddle,

    Could you tell us which font family you tried to use there?

    Regards,
    Kiran

    Thread Starter riddlediddle

    (@riddlediddle)

    I tried the standard fonts, given by the theme (‘Lato’,’Helvetica Neue’,Helvetica,Arial,sans-serif) under customize -> body -> Typography) and The Themes strips html.
    Then i tried different fonts like Arial, Verdana, Serif, Monospace, Cursive, Fantasy, Helvetica, Trebuchet MS and the content gets stripped also.
    i feel every font is affected.
    Only if i delete all content in the typography field, no custom fonts, just a empty field, everything works fine.

    Even if i edit the style.css or an other file, to change the font, the html gets stripped. Also the listing with dots (li).
    it affects directory starter, Supreme Directory, Whoop,

    it not affects Restaurant Directory (Kadence), Real Estate (Kadence), Yoga Studios (Kadence).

    Everything installed/imported with AyeCode.

    it also happened on other plugins, like Directorist!

    if i create a table an use the <th> tag, everything in this tag is bolded.

    sry for my bad english, i’m german.

    • This reply was modified 1 year, 1 month ago by riddlediddle.
    • This reply was modified 1 year, 1 month ago by riddlediddle.
    Thread Starter riddlediddle

    (@riddlediddle)

    tested with chrome.
    //Edit
    And firefox.

    • This reply was modified 1 year, 1 month ago by riddlediddle.

    Hi @riddlediddle,

    I checked on my test site but not sure how to reproduce it.

    Could you please open a support ticket on our site so we can check further? http://wpgeodirectory.com/support/

    Please add “FAO Kiran” and the our team will flag it for me.

    Regards,
    Kiran

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Some Style-Options doesn’t work’ is closed to new replies.