Support » Plugin: SyntaxHighlighter Evolved » Some source code line numbers are not printed

  • Resolved wordruman

    (@wordruman)


    Hello.
    I use version 3.6.1 on WP 5.8.2. And i have this snippet.

    public class ImageViewCustom extends AppCompatImageView {
        public ImageViewCustom(@NonNull Context context) {
            super(context);
        }
     
        public ImageViewCustom(@NonNull Context context, AttributeSet attrs) {
            super(context, attrs);
        }
     
        public ImageViewCustom(@NonNull Context context, AttributeSet attrs, int defStyleAttr) {
            super(context, attrs, defStyleAttr);
        }
    }

    And here’s the output:
    https://ibb.co/y4q8Fc2

    Line number 14 and 15 are not printed.

    Any idea why ? Thanks.

    • This topic was modified 6 months ago by wordruman.
    • This topic was modified 6 months ago by wordruman.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Jay (a11n)

    (@bluejay77)

    Hi @wordruman,

    It seems like there are some alignment issues in the screenshot. In the screenshot you provided, the lines 6-7 and 11-12 really should be on individual lines.

    I copied your code snippet and tested it on my test site, and had thirteen exact lines without any text wrapping. I am on WordPress 5.8.2 running Twenty Nineteen theme. I’m using block editor, and added the snippet using a Syntax Highlighter code block, and specified Java as the language.

    You can see the example here:

    https://alexmillspluginstest.mystagingwebsite.com/testing-syntax-highlighter/

    Since I couldn’t replicate the issue, I suspect that there may be a site-specific setup that’s causing the issues. Can you kindly share with us the exact steps you took to embed the code snippet? Are you using a classic editor or a block editor? Are you using a default WordPress theme?

    Please share screenshots of your Syntax Highlighter Settings as well so we can copy it and see if we can replicate this issue (under WP-Admin > Settings > SyntaxHighlighter).

    Please note, there may be something else installed on the site that’s causing problems. The quickest way to figure out if something is interfering is to test for a theme or plugin conflict.

    I know it’s less than ideal, but could you please try the following:

    – Temporarily deactivate all the site’s plugins except for Syntax Highlighter and clear your browser’s cache.
    – Then test the code snippet again. If the issue resolves, then we’ll know that another plugin is conflicting here. You can re-enable your plugins one by one, in between, until you find the one causing the conflict. You can leave it disabled or reach out to the plugin developer for a fix.

    If disabling plugins doesn’t help, it may be the theme.

    – Temporarily switch your theme to a WordPress default theme like Twenty Twenty. Then try Syntax Highlighter code snippet again. If the issue resolves, then you know it’s a problem with the theme, and you can reach out to the theme developer for a fix.

    Let us know how that goes.

    Thread Starter wordruman

    (@wordruman)

    Hello.

    I haven’t tried switching theme. But on my site, the vertical scrollbar does not appear. Seems like that’s the problem.

    But, if i double click it, The line numbers problem solved.

    https://ibb.co/3syy8PC

    That’s when i use the version 3.x. Problem solved if switched to version 2.x

    https://ibb.co/w6dzCSM

    Plugin Support Gaurav (a11n)

    (@gaurav984)

    H again,

    Thanks for the update and letting us know that you were able to resolve the issue by using version 2x of the plugin.

    If you like we can help test this further to resolve the issue happening with v 3.x of the plugin on your site.

    For this, please send us the following information.

    – What’s the active theme on your website?
    – Are you using Block Editor or the Classic editor?

    Thread Starter wordruman

    (@wordruman)

    Yes. Problem solved by using version 2.x.

    – What’s the active theme on your website?
    I use ColorMag.
    https://wordpress.org/themes/colormag/

    – Are you using Block Editor or the Classic editor?
    I use Block Editor.

    • This reply was modified 5 months, 1 week ago by wordruman.
    Plugin Support Gaurav (a11n)

    (@gaurav984)

    Hi again,

    Thanks for getting back to us! I checked, and from what I can see, the issue is happening mainly because of some of the font CSS in the ColorMag theme. I tried the same code with Twenty Twenty-One, and the code block shows up properly.

    Screenshots

    – Using Twenty Twenty-One theme: https://d.pr/i/KMg4S4
    – Using ColorMag theme: https://d.pr/i/bpaQ6M
    – After adding padding to the bottom of the numbers in ColorMag theme: https://d.pr/i/r3YweA

    I hope this helps; please feel free to contact us if you have any other questions.

    Best,

    Thread Starter wordruman

    (@wordruman)

    I see.

    So the problem lies on the theme. Alright, thanks for your help !

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.