[resolved] Some sites are missing in network admin section (6 posts)

  1. devpaq
    Posted 4 years ago #

    I created 5 sites in my network. I am able to access the dashboard of each site directly without a problem.
    But if I go to the Network Admin Dashboard it shows that I have only 3 sites in my network.

    A few other things I will point out:
    - The 2 missing sites are the last 2 I added.
    - The "SITE_ID_CURRENT_SITE" and "BLOG_ID_CURRENT_SITE" is set to 3
    - Some of the plugin settings that show for all sites are not showing for these 2 sites (when I am in that site dashboard)
    - If I try to manually go to the edit site page (by changing the url from site-info.php?id=1 to site-info.php?id=4 I am told "You do not have permission to access this page." I am logged in as the super admin - and I checked the database and I see I am set to user_level 10 and capabilities set to administrator for all 5 sites.

    Any help would be appreciated. Thanks.

  2. You're at /wp-admin/network/sites.php right?


    Where are you looking for those?

  3. devpaq
    Posted 4 years ago #

    Correct I am at /network/sites.php

    In my config file

  4. Okay, those config settings don't matter ... except they do.

    I think I know what's up.

    Go to the wp_blogs table and check the site ID on the new sites. I bet they're a 1.

    Change them to 3 and then check the wp_sitemeta table, where you'll probably have to make the same change.

    Check out http://halfelf.org/2010/dig-yourself-out-of-a-hole-multisite-edition/ - I did this to myself once :)

  5. devpaq
    Posted 4 years ago #

    Thanks, you solved it!

    It was actually the other way around - the site_id were both 3 ( I guess it got it from the config) - switching it back to 1 solved my problem.


  6. That works too :D

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.