Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Some shortcodes work, but others don’t

  • Resolved piranhapete3

    (@piranhapete3)


    I’m in the middle of building a website that uses Photonic. I noticed recently that a shortcode for a specific Flickr gallery will work fine, but a shortcode for a general search will not show anything.

    Here are example shortcodes I’ve tried:
    This shortcode works great: [photonic type=’flickr’ view=’photos’ user_id=’151210219@N03′ tag_mode=’any’ sort=’relevance’ privacy_filter=’1′ caption=’title-desc’ layout=’random’]
    This was created with the shortcode generator, but it doesn’t show anything. I’m interested in searching all users for photos by a search term with this shortcode.
    [photonic type=’flickr’ view=’photos’ tags=’alaska’ tag_mode=’all’ text=’alaska’ sort=’relevance’ privacy_filter=’1′ columns=’auto’ layout=’square’]

    Troubleshooting I’ve tried:
    I’ve deleted the plugin as well as any tables and options that I could find, and then I reinstalled the plugin and set it back up. It still doesn’t work.
    I’ve looked for plugin conflicts, but I didn’t find any.
    I’ve authorized it with Flickr multiple times, but it still doesn’t work.

    Do you know what could be interfering with some shortcodes but not others? If you are interested in taking a look, I can share login credentials and links (they are currently behind a Coming Soon page).

    Thanks in advance for any help you can give,
    Pete

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sayontan

    (@sayontan)

    From what I can see in the code, it looks like unless the user_id is defined, Photonic will not look for the photos. This is not how the code was when written originally about 10 years ago, but it looks like when I built out the gallery wizard in 2018, I made a mistake and erroneously coded in the dependency. It wasn’t caught in the past 2.5 years because probably most people use Photonic just to display their own photos.

    I will rectify this in the next release.

    Thread Starter piranhapete3

    (@piranhapete3)

    Thanks for your reply. That makes sense. I look forward to the next release. Thanks for making this plugin available.

    Plugin Author Sayontan

    (@sayontan)

    I have released 2.65, which, hopefully, should fix the above.

    Thread Starter piranhapete3

    (@piranhapete3)

    The update worked. Thanks so much!!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.