Support » Plugin: Simple Membership » Some serious problems and a few questions

  • Resolved Alexander

    (@aivanov12)


    Hello! Thanks for your wonderful plugin. I have some serious problems and I am asking for help.

    1. While editing a post, suddenly the plugin logs me out and I get an error. I can’t even save the post in drafts. After that, the only way to fix the problem is to clear the browser’s cache and cookies. But after a few days the problem appears again. I have turned off all types of caching (as a result, the site slowed down dramatically). No improvement.

    2. Very often the plugin logs users out, and after they log in again, the articles are still locked. I can’t reproduce the problem as it happens randomly, with different users and in different situations.

    3. When giving someone access for a month, the plugin counts less than one full month. Example: I manually create an account on 25/08/2022 at 10:00 AM. The account expires on 24/08/2022 at 00:00 AM.

    Now two questions:

    1. I would like to ask you, is it possible to send the same email automatically to all my subscribers at once?

    2. I would like to ask if there is a possibility to export the plugin settings including the subscribers?

    • This topic was modified 3 months, 1 week ago by Alexander.
    • This topic was modified 3 months, 1 week ago by Alexander.
    • This topic was modified 3 months, 1 week ago by Alexander.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 16 through 29 (of 29 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    I suspect some type of caching issue or something is triggering your cookies. It might be related to your browser settings.

    Kind regards.

    Thread Starter Alexander

    (@aivanov12)

    That’s what I wanted to explain to you, that I suspected the cache might be a problem. I used LiteSpeedCache with the settings you recommended – opting out of caching the plugin cookie and plugin pages. So I cleared and turned off all caching. For a month I tested but the problem persisted. Then turn the cache back on as I don’t see any change. The problem occurs on all sorts of different browsers, including my Chrome, which uses default browser settings, and doesn’t have any cookie restrictions.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, someone in the forum provided a solution using LiteSpeed cache. Please check the following forum post. Let me know if this helps you.

    https://wordpress.org/support/topic/register-form-input-boxes-too-long/#post-15709345

    Thank you.

    Thread Starter Alexander

    (@aivanov12)

    I keep testing and checking different options where the problem might lie. Could you please let me know if the modified heartbeat and modified wordpress cron could be interfering with the plugin and causing the above mentioned problem? Please see the two pictures:

    https://i.ibb.co/17VHZCG/1.jpg

    https://i.ibb.co/TY6BYKZ/2.jpg

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, unfortunately this could be related to a number of issues that are not related to our plugin. For example: The settings in your server, or plugin/theme conflict and or site configuration. This is beyond the scope of this free support forum unfortunately.

    You might like to submit a paid support ticket.

    https://simple-membership-plugin.com/paid-support-simple-membership-plugin/

    Kind regards.

    • This reply was modified 2 months, 2 weeks ago by mbrsolution.
    Thread Starter Alexander

    (@aivanov12)

    Please tell me, is it possible that the changed settings above prevent the plugin from working normally?

    Please see the two pictures:

    https://i.ibb.co/17VHZCG/1.jpg

    https://i.ibb.co/TY6BYKZ/2.jpg

    Plugin Support mbrsolution

    (@mbrsolution)

    Sorry but I don’t know what am I looking at in the two images above. I have never used that theme and or plugin. You are the first to ever report an issue like this. Like I mentioned above this could be related to a number of issues that are not related to our plugin. For example: The settings in your server, or plugin/theme conflict and or site configuration. This is beyond the scope of this free support forum unfortunately.

    Kind regards.

    Thread Starter Alexander

    (@aivanov12)

    I have come across several posts by various users on your forums, here, and on your site where people are complaining about the same problem as mine. No one has found a solution so far and you are failing to offer them a solution. I am happy to inform you that I think I have found a solution to the problem. I am currently testing and need a few days then I will let you know. And I will ask you to add this solution to the plugin instructions so that all people who use this wonderful plugin know it.

    Thanks again for your wonderful plugin! I am extremely pleased with it!

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    I am happy to inform you that I think I have found a solution to the problem. I am currently testing and need a few days then I will let you know.

    Please do so 🙂 I look forward to your solution.

    Kind regards.

    Thread Starter Alexander

    (@aivanov12)

    I am so happy! The solution to the problem works!

    What I have done is add the “swpm_session” cookie in the cache exclusion section.

    Please see the screenshot: https://i.ibb.co/SsBhnvD/cats.jpg

    This is found in the LiteSpeed Cache plugin settings. I believe this solution will work for all other users experiencing my problem, no matter what caching plugin they use. They just need to add this cookie to the cached excluded section.

    In the meantime, could you please let me know if the plugin has a feature to send an email to all subscribers to notify them to clear their browser cache and cookies to make sure no trace of the problem remains in their browsers?

    This is the most wonderful plugin! I’m thankful it’s there! And that it’s free for those who can’t afford to pay.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, thank you for sharing your solution 🙂 I am sure this will help others with a similar issue as yourself.

    In the meantime, could you please let me know if the plugin has a feature to send an email to all subscribers to notify them to clear their browser cache and cookies to make sure no trace of the problem remains in their browsers?

    Unfortunately we don’t have an addon to cater for what you need. Services like Mailchimp, Aweber etc can help you with this. However you might like to use the After Login Redirect addon to redirect your members to a page after login in with a message.

    https://simple-membership-plugin.com/configure-login-redirection-members/

    Kind regards.

    Thread Starter Alexander

    (@aivanov12)

    Thank you so much. I thought of the redirect option. But it is not working for me because the redirect plugin is not working correctly for me. When enabled, it redirects to a non-existent page. Is it possible to fix this problem. I will be so happy and grateful.

    Best wishes and blessings,
    Alexander.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi Alexander, can you start a new support thread. It will make it much easier for us to assist you further.

    Thank you.

    Thread Starter Alexander

    (@aivanov12)

    Okay, dear. Thanks. Blessings.

Viewing 14 replies - 16 through 29 (of 29 total)
  • You must be logged in to reply to this topic.