Support » Plugin: Categories by Tag Table » Some posts not being categorized correctly

  • Resolved lachele


    Go to the link below (or the next if the first doesn’t work — it’s about to move) (if the first doesn’t work)

    Consider the tag AMBER. The table says there is one entry in the Legacy category. But, if you click on the “1”, you get a “Nothing Found” error. You get this error because the single post with tag AMBER is in the category FAQ. However, the same post is correctly entered into the FAQ column under the tag Input Files.

    There should aso only be one post for the Derivative tag in category Legacy.

    The other entries all seem to be ok.

    The only thing I can see that is obviously different about the category Legacy is that I provided a description for it, but not for the others.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author haroldstreet


    Hi – Sorry i’ve only just found your post!

    That is really strange – is there anything different about those Categories or Tags from the others? Such as are any sub-cats/tags or have the got different slugs structures? or anything?



    No worries.

    I can’t see anything. All of the categories and some of the tags are listed below. The slugs are all really boring, and there are no hierarchies.

    BTW, go to the new site now (

    I even deleted the descriptions (I had added one for “Legacy” while testing), then deactivated and reactivated the plugin. But, it still behaves the same.

    In the table on the Dashboard “Categories” page, “Legacy” is listed as having only one associated post, and it is the correct one (one of the two assigned to the tag “Derivatives” in the Cats-by-Tags table).

    The URL-acess works. For example, there should be three posts associated with the tag “AMBER”, all in the category “FAQ”.

    Cats and some tags:

    Category Slug
    FAQ faq
    HOW-TO how-to
    Legacy legacy
    Troubleshooting troubleshooting
    Tutorial tutorial
    Uncategorized uncategorized

    Tag Slug
    AMBER amber
    BFMP bfmp
    Build Options build-options
    Carbohydrate Builder carbohydrate-builder
    Derivatives derivatives
    Downloads downloads
    Files files

    Plugin Author haroldstreet


    Hi again
    Is it possible that you have some deleted or private posts that are being miscounted?

    Otherwise i’d suggest you could try running a CHECK TABLES command on your Word Press MySQL database

    Sorry i just don’t know what is causing this

    Plugin Author haroldstreet


    Or is it possible that some of the affected posts have been classified differently in earlier versions?

    Plugin Author haroldstreet


    Hello again
    i’ve been experimenting with my own site, and after some effort i managed to reproduce the error that you are seeing by adding different classifications to a post in different combinations and finally deleting it.

    Finally the problem went away when i emptied the post trash folder and permanently deleted them all

    Can you try empting your trash and see if that helps?


    There wasn’t any trash to delete on that site. There was a single trash post in one of the other sites. I deleted it, but the behavior hasn’t changed.

    I checked my tables. They are all OK.

    There are some private posts, but they aren’t being miscounted, best I can tell. The Legacy category contains one public post and no private or deleted. The FAQ category contains 6 private posts, but none of the private ones also have the “AMBER” tag. The other two private posts are in category “HOW-TO”.

    There are more incorrect entries in the table now than there were when I first posted this. For example, there are actually 2 Tutorials, total, and neither has tag GLYCAM or Glycoprotein Builder. But, both have do tags “BFMP”, “Downloads”, “ring conformation” and “Software”. Only “ring conformation” shows up as a tag for them.

    I just tried changing the label (not the slug) for “ring conformation” to “Ring Conformation”. I know I had done that for other tags, but doing that didn’t change any behavior that I can tell.

    I said this before, more or less, but here it is in clearer form:

    In the table at the URL below, the tag “AMBER” has 0 FAQ entries and 1 Legacy entry. However, there are actually 3 FAQ entries (all public) and no Legacy entries.

    If you use the URL to access the info, it comes up correctly, logged-in or not:

    3 posts (correct):

    0 posts (correct):

    3 posts, total, with tag AMBER, all public and published:

    Let me know if there is any other troubleshooting I can do.

    Plugin Author haroldstreet


    OK i’m still confused

    You could try to replace line 182 in the plugin file cat-by-tags-table.php with…

    $countsql.=”WHERE col.term_taxonomy_id = “.$col->term_id.” AND col.term_order = 0 “;

    and see if that changes anything.

    and if that doesn’t work would you consider exporting your entire wordpress MySQL database in to a zip file and emailing it to me at
    then i can try and experiment on it directly?



    That didn’t change anything I can see. I just sent the db dump.

    Plugin Author haroldstreet


    OK problem is now solved and update 2.08 released


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Some posts not being categorized correctly’ is closed to new replies.