The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] Some pages not loading (6 posts)

  1. J M
    Posted 4 years ago #

    Today some of my pages are not loading when clicked in the nav menu. I have no idea why. The links are correct. Nothing has been changed recently. Is it a host problem or has something gone wrong in WP? I've tried to analyse using Firebug but no luck.

    Site is http://hiphopinenglish.com and an example of a menu page not loading is http://hiphopinenglish.com/contact/

    Thanks in advance

  2. jonradio
    Posted 4 years ago #

    This is known as the "White Screen of Death". There is trouble-shooting documentation on it here:

    But my own experience says you should first try editing wp-config.php and turn on debugging just to resolve this problem (turn it off once you're done):
    You're like to get a lot more info on the error.

  3. J M
    Posted 4 years ago #

    OK. So I tried the debugging option you mentioned. (Thanks also for the info on White Screen Of Death).

    These are the errors it returned.

    Warning: include(/home/hiphopinenglish/hiphopinenglish.com/wp-content/wp-cache-config.php) [function.include]: failed to open stream: No such file or directory in /home/hiphopinenglish/hiphopinenglish.com/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7

    Warning: include() [function.include]: Failed opening '/home/hiphopinenglish/hiphopinenglish.com/wp-content/wp-cache-config.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/hiphopinenglish/hiphopinenglish.com/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7

    Notice: Use of undefined constant AIOFAVICON_TEXTDOMAIN - assumed 'AIOFAVICON_TEXTDOMAIN' in /home/hiphopinenglish/hiphopinenglish.com/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 37

    Other than turning off the two offending plugins, what can you suggest from here?


  4. jonradio
    Posted 4 years ago #

    Based on this forum thread
    I think you can eliminate All In One Favicon as the culprit.

    To get things working, I would disable WP Super Cache and turn off Debugging, and see if everything works properly. If you can't figure out the WP Super Cache problem, including doing some searching through the forums, I would post the problem in http://wordpress.org/support/forum/plugins-and-hacks to get some help with it. Not having experience with the plugin, my first inclination would be to uninstall it and re-install it.

  5. J M
    Posted 4 years ago #

    Thanks for your help jonradio. I'm stuck! I've disabled WP Super Cache and looked through the supports forums for the WP Super Cache entries. I've deleted WP Super Cache following the steps in the readme (though interestingly I didn't have any entries for it in .htaccess).
    Problem persists. Some pages I can see, some I can't.
    Bit desperate now.

  6. J M
    Posted 4 years ago #

    Problem solved. After some panic and strands of hair ripped out later, it was a plugin error! A mistyped : instead of ;. Thanks for help.

Topic Closed

This topic has been closed to new replies.

About this Topic