Support » Plugin: YITH WooCommerce Social Login » Some of the permissions below have not been approved for use by Facebook

  • Hi there,

    Thanks for creating this awesome plugin!

    It seems like one of the permissions your plugin is asking for, is no longer automatically approved by Facebook. ‘Public profile’ and ’email address’ are still approved, so the issue must be with ‘personal description’.
    Facebook is asking to submit this permission for review, where I have to show why it is necessary. I also have to link to a privacy policy and make some other settings.
    Any advice or solutions for this?

    This is what Facebook asks for:
    For each permission:
    – Explain how your app uses this permission to create a great user experience.
    – Provide step-by-step instructions on how to reproduce that experience when we test your app.
    – Please also provide all necessary passwords, test user credentials and links to staging servers to successfully login with Facebook.
    – Provide a screencast.
    https://developers.facebook.com/docs/facebook-login/review/how-to-submit

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve tried to submit my app for approval, but it was rejected with the following message:

    Feedback From Your Last Submission (Today at 3:03am)
    Your screencast doesn’t show how this permission is used in your app, and we weren’t able to reproduce the permission on our end either. Please upload a new screencast and update your submission notes before you resubmit. Learn more about making and submitting a screencast.

    Notes From Your Reviewer
    Hi, the user_about_me provides access to a person’s personal description (the ‘About Me’ section on their Profile). This permission does not give access to a person’s public profile data. A person’s name, profile picture, locale, age range and gender are included by default with the public_profile permission.

    I’m seeing the same problem. I sent in a message to YITH pre-sales support to see if there is a workaround. Social Login is nice but not worth the headache of going through an approval process.

    • This reply was modified 2 years, 10 months ago by  tecnotecpc.

    I was replied to saying that if I purchase the plugin that they’d send me code to fix the problem.

    Hello guys,

    Reading the code application from GitHub, I figured out what we should change in order to remove these additional permissions.

    Do it by your own risk.

    Open this file from your wordpress homedir: …/public_html/wp-content/plugins/yith-woocommerce-social-login/includes/hybridauth/Hybrid/Providers/Facebook.php

    Between line 18 and 22 you´ll find the following:

    		/**
    	 * default permissions, and a lot of them. You can change them from the configuration by setting the scope to what you want/need
    	 * {@inheritdoc}
    	 */
    	public $scope = "email, user_about_me, publish_actions";
    
    

    Remove “user_about_me” and “publish_actions”.
    Add two tags: “public_profile” and “user_friends“.
    Your line 22 should stay like this: public $scope = “email, public_profile, user_friends”;
    Save your file, try again and be happy 😉

    by default facebook only allow us to receive three parameters:
    1 – email
    2 – public_profile (id, cover, name, first_name ,last_name, age_range, link, gender, locale, picture, timezone, updated_time, verified)
    3 – users_friends (

    Cya!

    • This reply was modified 2 years, 8 months ago by  patricksponte.
    • This reply was modified 2 years, 8 months ago by  patricksponte.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Some of the permissions below have not been approved for use by Facebook’ is closed to new replies.