Support » Plugin: WP Photo Album Plus » Some notices when debug on

  • Resolved Jakobuz

    (@jakobuz)


    Hai Jacob,

    just to inform you:
    with “define(‘WP_DEBUG’, true)”, I’m getting the following notices:

    Notice: Trying to access array offset on value of type null in …/public_html/staging/wp-content/plugins/wp-photo-album-plus/wppa-common-functions.php on line 1009

    same on: …/plugins/wp-photo-album-plus/wppa-common-functions.php on line 1018

    and same on: …/plugins/wp-photo-album-plus/wppa-common-functions.php on line 1035

    Thanks and greetings,
    Jakob

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    This means that wppa_initialize_runtime() has not yet been called, so i need to know how to reproduce this; c.q. what did you do exactly to get these warnings?

    Thread Starter Jakobuz

    (@jakobuz)

    Hi Jacob,
    Well, as far as I know, the notices showed up when I had updated WPPA to the latest verion (7.3.02.007). So, actually that was all: no new pictures uploaded, no new albums, or whatever.
    But this only occurs on our staging website. On the production website, which is for about the same, I did not update WPPA yet (version 7.2.16.006 is still active), and there are no notices with WP_DEBUG on true)

    • This reply was modified 1 year, 5 months ago by Jakobuz.
    Thread Starter Jakobuz

    (@jakobuz)

    hi Jacob,
    The notices occur when PHP version 7.4 is set.
    All is well with PHP version 7.3
    I hope you find this conclusion useful … I don’t know yet what has changed with the new PHP-version, but when I have time, I’ll give it some attention.
    Greetings Jakob

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I can not reporduce this, but it should be fixed in 7.3.03.
    Please test it when released.

    I just discovered that i can switch to php 7.4, so now i can reproduce it.
    Thanx for the report. Will be fixed.

    • This reply was modified 1 year, 4 months ago by Jacob N. Breetvelt. Reason: I just discovered
    Thread Starter Jakobuz

    (@jakobuz)

    Awesome, thank you Jacob!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Some notices when debug on’ is closed to new replies.