Support » Plugin: WP Hide & Security Enhancer » Some nasty bug is going on with admin url the the last couple of days

  • Resolved drazon

    (@drazon)


    Well I realized that on three cpanel servers(Dedicated & VPS) that I manage all websites with WPHSE and renamed the admin_url option throw 404s in the WP backend. Paths like https://mydomain.com/newbackendurl/plugins.php throw 404 while if I manually change the url to https://mydomain.com/wp-admin/plugins.php it loads and renders the page normally and at the same time it rewrites the url to https://mydomain.com/newbackendurl/plugins.php. However if you try to make changes or save anything you get again a 404.

    Some facts:
    1) The option “Block default Admin Url” doesn’t change anything
    2) It doesn’t happen with the “New wp-login.php” option just the “Admin Url” option.
    3) I tried multiple themes and disabled all plugins
    4) I disabled the server firewall and modsecurity with no luck
    5) I think the issue is some conflict with the latest version of Apache/PHP. The only common that those servers/websites have is cPanel/CentOS/Apache/PHP version

    Example environment

    /etc/redhat-release:CentOS release 6.10 (Final)
    /usr/local/cpanel/version:11.74.0.9
    /var/cpanel/envtype:kvm
    CPANEL=release
    Server version: Apache/2.4.37 (cPanel)
    Server built:   Oct 29 2018 18:29:24
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 7.0.32 (cli) (built: Oct 30 2018 21:21:05) ( NTS )

    I noticed that on all servers the Server built and PHP built times are almost identical and it’s when this issue started. It has to be some conflict with the latest APACHE/PHP versions. cPanel must have forced an update to EasyApache 4 and the above builds as I didn’t do it.

    Does anyone else with cPanel experience this issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have exactly the same problem. Also cPanel/EasyApache4 on three different WordPress installations. I have solved this temporarily:
    Remove all entries from .htaccess, delete the PlugIn – first of all so that everything works again.

    I have very identical settings like you.

    So just to make this clear after those steps you mentioned did you reinstall the plugin and set a custom admin_url and it works now? Because if anyway I set a custom admin url on my websites none works.

    Same issue here.

    2 of my servers and all websites on them have recovered after 2 days. I can’t track down what caused this. I’m marking the thread as resolved for now but I would really like to know what was the conflict…

    Plugin Author tdgu

    (@tdgu)

    Thanks for your feedback. This might be caused by a bug on server environment which got fixed meanwhile.
    Please update this topic if the problems come back.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Some nasty bug is going on with admin url the the last couple of days’ is closed to new replies.