WordPress.org

Forums

Some mod_rewrite help please. (7 posts)

  1. ChrisOwens
    Member
    Posted 11 years ago #

    Anyone at all know?
    I've searched this forum several times, but never find a real definitive answer to this problem. And the threads that have discussed this previously all end without a solution.
    Please help.

  2. Stevarino
    Member
    Posted 11 years ago #

    Sadly, this isn't a mod-rewrite problem but a php problem. To fix this you would have to locate the function adding those hyphens and correct that. I searched for a few minutes but couldn't find anything.
    Let me say that I do understand what you're saying. When I fired up WP for the first time I wanted underscores too. But because I didn't have to worry about maintaining permalinks and I remember reading somewhere that google apparently prefers hyphens to underscores, I let it go.
    But could I suggest that this be added to WP's permalink settings? This could be very important for migrating weblogs.

  3. OperaManiac
    Member
    Posted 11 years ago #

    the advantages of having post slug field i assume!

  4. ChrisOwens
    Member
    Posted 11 years ago #

    Thanks allusion, but that didn't work... I got 404's... is it possible that using the SQL query also needs some editing of the mod_rewrite stuff?
    I'm not too worried about future links, but my past links drove plenty of traffic to my site... so had that suggestion worked I would have been totally happy.
    Thanks again,
    Chris
    PS: I agree with Stevarino, this might be a good option to include for those users that are thinking of moving from MT to WP.

  5. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    *sigh*
    I forgot the mod_rewrite rules had been changed in the CVS.
    Change
    [0-9a-z-]
    to
    [0-9a-z-_]
    In all the rules.

  6. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    And this has now been included in the CVS.

  7. ChrisOwens
    Member
    Posted 11 years ago #

    ok, I'm running the latest CVS, and have replaced the old mod-rewrite stuff in my .htaccess file with the new stuff ... and now get an error 500 every time.
    So I've gone back to the old .htaccess stuff, and am still running the new CVS copy and it works fine.?.
    I'm beginning to think I'm cursed. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.