Support » Plugin: Fast Velocity Minify » some minify issue

  • Resolved johndos

    (@johndos)


    Hello mate, I am having a small issue with FVM, I have recently installed a plugin named WooCommerce Product Categories Selection, I have made some CSS and JS changes and now here comes the issue. When logged in via administrator everything shows as should (I have cleared cache, see image attached below) but when trying to view in chrome incognito it appears wrong, the images do not show and the text doesn’t go bold as it should.
    I have cleared cache in FVM and WPSC also enabled dev mode and cleared cache in cloudflare, I even checked the file that FVM serves and edited that and inserted the code manually (minified ofc) but nothing did the trick, do you have any ideas?

    https://medicalfa.gr/wp-content/uploads/2019/12/category-widget.jpg

    • This topic was modified 9 months, 3 weeks ago by johndos.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Raul P.

    (@alignak)

    Disable the rocket loader and other minification settings on the speed tab, under cloudflare.
    Rocket loader can break scripts very easily and my official recommendation, is not to use it.
    https://i.imgur.com/tHqQrLx.png

    Only options you should enable there, are
    Polish (if you have a paid plan),
    Enhanced HTTP/2 Prioritization,
    Brotli

    All else disabled there.

    Also, purge the cache on cloudflare.
    Right after purge FVM, followed by any other cache plugin.

    disabled rocket loader, cleared all cache but the issue is still there. I even deleted the FVM cache manually the second time. Could the issue be the preload of WPSC? Although I refreshed it yday.

    Check this https://imgur.com/RSxY3fe

    • This reply was modified 9 months, 2 weeks ago by johndos.
    • This reply was modified 9 months, 2 weeks ago by johndos.
    Plugin Author Raul P.

    (@alignak)

    Yes, but look at the google chrome console.
    You still have another error that needs fixing.
    https://i.imgur.com/ltIFUYk.png

    This usually means, you have some inlined jQuery code on your page, loading before jquery has the chance to load.

    So you either

    a) manually edited your theme and pasted that code in the header.php too early, or
    b) you are merging but deferring jquery, meaning it will load after your code needs it, or
    c) there is a conflict when merging jquery and one of your scripts is taking over jQuery, causing it to be undefined.

    In your case, your earliest jquery inlined code:
    https://i.imgur.com/8cTiBMo.png

    And while jQuery is being merged and put in the header (correct), you must have enabled the option to defer it:
    https://i.imgur.com/K9A4t3q.png

    Therefore, the error is caused by you enabling defer javascript, which as the description explains, can break scripts and functionality.
    Your site requires jquery to be render blocking, so you cannot just enable the feature and pray that it works.

    You can try to keep the defer enabled and exclude jquery from being merged.
    If that doesn’t work, you must disable defer for javascript.

    The Skip deferring the jQuery library option worked though it puzzles me cause the JS was working as it should the only issue I had was the css that wasn’t inserted in the new minified css.

    Plugin Author Raul P.

    (@alignak)

    The css code was there, I think.

    What probably happened is that some of that inlined jquery, insert classes for the icons into elements, which were not working due to the deferring situation.

    Glad it’s fixed

    Nope the code wasn’t there that is why I was confused, it’s weird that it got fixed with that, cause the JS was working perfectly. The only thing that didn’t appear was the css changes, I checked all CSS in the min.css but wasn’t there, I even edited the css to manually add it but didn’t do the trick either. Anyway it was fun!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘some minify issue’ is closed to new replies.