WordPress.org

Forums

Polylang
Some links redirect to incorrect pages (4 posts)

  1. Tierra Quebrada
    Member
    Posted 1 year ago #

    Hi,

    Those are my current settings for

    Permalinks:

    http://www.tierraquebrada.com/%year%/%postname%/
    Static inital page instead of posts page

    Polylang

    Actually only 2 languages
    Detect browser language: on
    Use language code, as suggested with plugin wordpress seo
    remove language in permalinks
    Hide url for default language
    media translation: on
    Sync: all on

    Description:
    it's a working site and just now added polylang

    Problem:
    In some top level pages links doesn't work as expected and always redirect to posts page nor the correct static page.

    You can see in all top level pages redirected to same posts page
    http://www.tierraquebrada.com/vive-tu-propia-aventura/
    http://www.tierraquebrada.com/el-mundo-de-tierra-quebrada/
    http://www.tierraquebrada.com/quienes-somos/

    These 3 pages should show diferent information but all of them redirects to
    http://www.tierraquebrada.com/la-vieja-puerta-de-roble/
    (url to publish posts)

    Need more verification but for now seems all other pages and posts work fine.

    http://wordpress.org/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Polylang does not seem to be active on your site.

  3. Tierra Quebrada
    Member
    Posted 1 year ago #

    Hi,

    I disable it since nobody can acces top level pages when active.
    Upgraded to 1.1.4 but problem still persists.

    Any idea what cuold be happening?

    Thanks again :)

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Could you check that the problem still exists if you use a default theme such as twenty twelve and no other plugins activated, as your problem may be the result of a conflict.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.