Support » Fixing WordPress » Some images not visible on PC but visible on phone

  • Resolved fritzloest

    (@fritzloest)


    Hi. Some images do not appear on my laptop while they do appear on my phone. The same pictures are not visible in different browsers (Chrome and Avast). I’ve cleared out the caches in both browsers. The problem is not the ‘lazy loading’ nor ‘speed up image load times’ settings in Jetpack. My WP is latest version and PHP is 7.4. When I disabled all plugins (via health checker plugin) the problem persisted. I’ve scoured your posts, can’t find a solution. Would appreciate some help. Thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi there! I checked your site in Safari, Chrome, and Firefox, as well as Safari on iOS, and I’m seeing all six images each time (the header image, as well as the 5 post images).

    Can you share which images exactly are not showing up for you? When they do not show up, are all the images gone, or only some of them? Thanks!

    Hi .. thank you! On that particular page, the bottom three images do not appear, while the top two do appear. The header in general always appears fine. On this page: https://sacredriver.co.za/theoria/theoria-operatio/ .. the top two appear as well as the far right one below, while the other two don’t appear. It’s different on each page.

    That’s odd! I’m still unable to reproduce, but I asked a friend to check and they did see images missing on mobile.

    Do you happen to have any custom CSS entered in Customize > Additional CSS? If so, that could be causing issues.

    If not, it looks like your site is built using the SiteOrigin page builder. Have you tried reaching out to their team for support as well by any chance?

    I do have additional CSS, have had for a long time, whereas this behaviour is new. However, no CSS applicable to that particular section of the page. All CSS for these pages pertain to resizing the headings directly beneath the header image for responsiveness.

    Thank you for your assistance, appreciate it. I will follow your suggestion and ask SiteOrigin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.