Support » Fixing WordPress » Some images not showing up

Viewing 7 replies - 1 through 7 (of 7 total)
  • It looks like a caching issue to me. Have you tried clearing your cache?

    Clear your website cache, browser cache and if your host supports server caching, clear that too.

    Also, edit the page in Elementor and just make any tiny adjustment that’ll give you an option to save it and hit save. In my experience, just opening and saving the page sometimes resolves issues like this.

    Let me know how it goes. Cheers!

    I may have mixed up the Elementor part of your message.

    I just read that again and it seems the part of the site you’re experiencing issue with isn’t built with Elementor. You’re probably using the Elementor full width menu on the page that shows the icons.

    What builder are you using on the homepage?

    Hi @sukafia,

    I’m using classic editor. Also, it’s not only the homepage of my live site where the icons do not show up but in all pages where I didn’t use Elementor (using it for 3 pages only).

    Thank you for the swift reply!

    Hi @anneyu,

    You’re welcome.

    Try the cache suggestion and let me know.

    If you have a caching plugin activated on the site, you can disable it temporarily. Also ensure your plugins are up to date.

    I’d have loved to check if the site is throwing any errors but your URL isn’t visible. I understand you may not want to put it up in a public forum, I’ve been there.

    If the caching approach doesn’t fix it, disable all plugins and leave just the core plugins (WooCommerce and your page Builders). If you’re using 2 page builders, disable one temporarily and leave just the one that came with the theme.

    Hi @sukafia,

    I just deactivated Elementor and the icons finally showed up!
    I suppose I’ll just replace Elementor for the 3 pages I’m using it for.

    Thank you so much! You’re the best!

    I am glad I could help.

    Please, mark this topic as resolved. Cheers!

    PS: These page builders don’t play nice with each others at times. If you really want to use Elementor, you can raise the issue in the Elementor forum.

    Thank you so much!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.