Support » Plugin: AMP » Some images not loading (loading icon) in Firefox

  • Resolved dieter93


    `I have a strange problem. In Firefox, images are sometimes not displayed for me in AMP-Standard Mode. The images are loaded and shortly after a loading icon (spinner) is displayed and nothing happens with this images anymore.

    Mostly this error occurs with the first images (logo, feature images etc.).
    Sometimes the images load, but very often they don’t.

    I currently have this problem only in Firefox. Chrome, Opera etc. works.

    I have disabled all plugins except AMP to test, without success. If I deactivate AMP, then the images are displayed correctly.

    I have no caching active, just use Litespeed Cache plugin for displaying webp-images – nothing more.
    If I disable webp, then the error is still there too.

    WordPress lazy load are disabled via functions.php -> without success
    Firefox reset -> without success
    Test on a another PC with Firefox -> same problem

    Are they aware of such a problem?

    Can you take a look at it? It is a DEV website.

    Here is also a <a href=”; rel=”noopener” target=”_blank”>Screenshot</a>

    Thanks and Best regards

    • This topic was modified 1 year, 1 month ago by dieter93.
    • This topic was modified 1 year, 1 month ago by dieter93. Reason: Link fix

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter dieter93


    Sorry – here ist the Screenshot

    Thanks for reaching out. I can reproduce on occasions while testing in Firefox on Windows. It looks like on the occasions where the image remains in a loading state it’s being served as a webp image. If you’d like to share your Site Health information via this form we can inspect your current setup.

    Thread Starter dieter93


    Okay, I sent it off.

    Thank you for looking.

    Many thanks for sharing. Can you share if you’ve enabled any image optimization features of Litespeed cache other than the default?

    If you can use the AMP plugins suppression feature to disable Litespeed cache from running on AMP URLs I can test your site once more. While I can’t be sure that’s the cause we can rule it out before performing additional tests.

    Thread Starter dieter93


    I used the Litespeed Cache plugin only for webp images.

    I understand: I have disabled webp and also the Litespeed Cache plugin.
    Htaccess I also checked, it is empty except for the WordPress entries and a block that blocks XML-RPC.

    # BEGIN Disable XML-RPC Protocol
    <Files xmlrpc.php>
    Order Allow,Deny
    Deny from all
    # END Disable XML-RPC Protocol

    I have also tested all this before, unfortunately without success.

    Thanks for the update and testing. I’ve checked again and the issue remains although intermittently.

    From inspecting the response for that image it doesn’t seem like specific to the plugin. A 304 error appears for this requested image and while I do sometimes encounter this when checking your site with caching disabled in Firefox I don’t encounter it when checking from a private window. Can you open a private Firefox window and check once more? If the issue remains please temporarily switch to transitional mode and we can check your setup further.

    Thread Starter dieter93


    Thanks for your efforts!

    I had also tested the private mode of Firefox, with Firefox Cache and without.
    -> Problem is still present

    This is really strange, I also switched to Twenty Twenty-One for testing.
    -> Problem is still present

    I have activated the transitional mode. Normal version works, amp version does not.

    Thanks for checking. While we may need to file an issue on the amphtml GitHub repository let’s rule out any plugin conflicts before doing so. Can you follow the steps in this guide to test your site with only the AMP plugin running?

    Let me know if you need assistance with the above. I’ll also try to setup an environment similar to your own.

    Thread Starter dieter93


    Health Check and Troubleshooting is active and only the AMP plugin is running: same problem.
    I had already deactivated all plugins at the beginning.

    Thanks again for your effort.

    • This reply was modified 1 year, 1 month ago by dieter93. Reason: More infos

    Thanks for performing those checks. I’ve checked similar AMP environments on different hosing providers and I don’t encounter the issue with srcset images with AMP on any site other than your own.

    Do you have any other WordPress sites hosted on the same server or can you spin up another site quick from your hosting control panel to check whether this is server related?

    Thread Starter dieter93


    Good to know that it probably works in general. From the looks of it, I’m probably the only one with this problem. Anything else would be a bit strange, because I haven’t found any reports of this problem on the net. The problem has been around for a while for me, but I haven’t felt like tackling it yet.

    Yes, I have several websites on this hosting package with Apache, all stagging websites. I only used this hosting package for development.

    The live V-Server of this website is not using Apache. I am using Litespeed Enterprise in a Plesk environment and there I have the same problem.
    This is a completely different setup from the server point of view.

    OK – I’ll do some more tests and then see. I might also consider turning off AMP.

    Thanks for your efforts and I must say, very good support. Thank you.

    As I said, I will do some more tests for a few days and will report back here.

    It’s a strange one alright, I can’t see any issue with the markup or with any other site I’ve tested on. One test you could perform is to copy the site using a plugin such as Duplicator, replicating it using a separate hosting solution.

    Feel free to share any findings with us if you’d like us to do some additional testing on our side.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Some images not loading (loading icon) in Firefox’ is closed to new replies.