Support » Plugin: Adaptive Images for WordPress » Some images don’t work after activating plugin

  • Hello!
    I found your plug-in and I really like what it does.
    Sadly I can’t get it to run: It randomly doesn’t work with some pics in the media-library. After reinstalling it, other pictures are affected.

    The problem in detail:
    Some pictures just aren’t shown on the homepage nor in the media-library. When I type in the URL by hand, I get sometimes a “Forbidden – You don’t have permission to access /wp-content/plugins/adaptive-images/adaptive-images-script.php on this server.” One picture where this happens now is http://www.wurmweb.at/wp-content/uploads/2017/12/Cornflakes-Kekse.jpg

    I kindly ask for your help!
    Thank you very much,
    Manuel

    Here is the debug-info:

    Debug info
    
    ✔ PHP GD library is installed.
    
    ✖ Image cache directory has not been created.
    
    But this is probably because the cache has not been accessed yet. 
    After accessing your website from a mobile device the directory should be automatically created.
    
    /usr/www/users/seitenn/wurmweb/wordpress/wp-content/cache => drwxr-xr-x
    
    ✔ Installation .htaccess file is setup OK.
    
    /usr/www/users/seitenn/wurmweb/wordpress/.htaccess => -rw-r--r--
    
    ❖ Adaptive images settings dump:
    
    array(14) {
      ["resolutions"]=>
      array(3) {
        [0]=>
        int(1024)
        [1]=>
        int(640)
        [2]=>
        int(480)
      }
      ["cache-directory"]=>
      string(21) "cache/adaptive-images"
      ["watched-directories"]=>
      array(2) {
        [0]=>
        string(18) "wp-content/uploads"
        [1]=>
        string(17) "wp-content/themes"
      }
      ["jpeg-quality"]=>
      int(75)
      ["browser-cache"]=>
      float(180)
      ["landscape"]=>
      bool(false)
      ["hidpi"]=>
      bool(false)
      ["cdn-support"]=>
      bool(false)
      ["sharpen-images"]=>
      bool(false)
      ["watch-cache"]=>
      bool(false)
      ["version"]=>
      string(6) "0.6.64"
      ["sanitized"]=>
      bool(true)
      ["wp-content-dir"]=>
      string(51) "/usr/www/users/seitenn/wurmweb/wordpress/wp-content"
      ["wp-content-url"]=>
      string(32) "http://www.wurmweb.at/wp-content"
    }

    And here the diagnostics:

    System information
    
    Web Server	
    Apache
    
    Document Root	
    /usr/www/users/seitenn/wurmweb/wordpress/
    
    PHP	
    7.1.12
    
    PHP Time Limit	
    240
    
    PHP Memory Limit	
    384M
    
    PHP Post Max Size	
    20M
    
    PHP Upload Max Size	
    20M
    
    PHP Max Input Vars	
    1500
    
    PHP Display Errors	
    Yes
    
    PHP Error Log	
    MySQL	
    5.5.58-0+deb8u1
    
    MySQL Ext/mysqli	
    Yes
    
    MySQL Table Prefix	
    wp_
    
    MySQL DB Charset	
    utf8
    
    WP	
    4.9.1
    
    WP Multisite	
    No
    
    WP Debug Mode	
    No
    
    WP Site url	
    http://www.wurmweb.at
    
    WP WP Home url	
    http://www.wurmweb.at
    
    WP Permalinks	
    /%postname%/
    
    WP home path	
    /usr/www/users/seitenn/wurmweb/wordpress/
    
    WP content dir	
    /usr/www/users/seitenn/wurmweb/wordpress/wp-content
    
    WP plugin dir	
    /usr/www/users/seitenn/wurmweb/wordpress/wp-content/plugins
    
    WP content url	
    http://www.wurmweb.at/wp-content
    
    WP plugin url	
    http://www.wurmweb.at/wp-content/plugins
    
    WP Locale	
    de_DE
    
    WP Memory Limit	
    40M
    
    WP Max Upload Size	
    20mb
    
    WP Active plugins	
    Accelerated Mobile Pages v.0.9.71 by Ahmed Kaludi, Mohammed Kaludi
    Adaptive Images for WordPress v.0.6.64 by Nevma
    Antispam Bee v.2.7.1 by pluginkollektiv
    Category Family Tree v.1.0 by Nasibu Njoka
    Category Featured Images - Extended v.1.52 by CK MacLeod
    Category Post list Widget v.2.0 by Stark Digital.
    Contact Form 7 v.4.9.2 by Takayuki Miyoshi
    Super Search - Custom Post Types v.1.0.0 by Shawn Wernig http://www.eggplantstudios.ca
    FastWP Theme extension for Corpus Christi Theme v.1.0 by FastWP
    FastWP Redux extension for Corpus Christi Theme v.1.0 by FastWP
    Google XML Sitemaps v.4.0.9 by Arne Brachhold
    Insert Headers and Footers v.1.4.2 by WPBeginner
    MailChimp for WordPress v.4.1.13 by ibericode
    Open Search Document v.3.0.0 by johnnoone, pfefferle
    PDF & Print by BestWebSoft v.1.9.8 by BestWebSoft
    Redirector v.3.0.1 by Ralf Hortt
    Rename wp-login.php v.2.5.5 by Ella Iseulde Van Dorpe
    rtSyntax v.1.0.5 by rtCamp
    External Links v.6.8.1 by Denis de Bernardy & Mike Koepke
    Simple Lightbox v.2.6.0 by Archetyped
    Page Builder by SiteOrigin v.2.6.0 by SiteOrigin
    Sub Categories Widget v.1.5 by BrokenCrust
    Sucuri Security - Auditing, Malware Scanner and Hardening v.1.8.11 by Sucuri Inc.
    WP-Ban v.1.69 by Lester 'GaMerZ' Chan
    WP Edit v.4.0.2 by Josh Lobe
    WP-Pro-Quiz v.0.37 by Julius Fischer
    WP StopSpam v.1.0 by virtuaSOFT
    WP Updates Settings v.1.1.4 by Yslo
    ZillaLikes v.1.1.1 by ThemeZilla
    
    WP MU plugins	
    
    • This topic was modified 3 years, 2 months ago by webwurm.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takis Bouyouris

    (@nevma)

    Hello, my friend,

    Forgive my tardy reply, but I must have missed the notification for your message.

    Now, from what I gather from the debug info that you have shared with me the Adaptive Images has probably not actually run, by that time. The message says “Image cache directory has not been created.” and this means that actually no image had been resized by that time!

    I did try to check that specific image you mentioned http://www.wurmweb.at/wp-content/uploads/2017/12/Cornflakes-Kekse.jpg but it seems that the plugin is not active at the moment. Do you think you can enable it for me so that I can take another look or help me debug the issue somehow?

    Cheers,
    Takis

    Thread Starter webwurm

    (@webwurm)

    Hello!
    No problem, I’m happy you are willing to help!

    I switched the PlugIn on now again – and you can see directly on my homepage, that some pics don’t work: http://www.wurmweb.at

    I leave it enabled for now, but I soon need to switch it off due to its heavy impact.

    Thank you very much!
    Manuel

    Plugin Author Takis Bouyouris

    (@nevma)

    Hello, again,

    Hmm, it seems that now all your images return a 403 (Forbidden) error. Is it possible that the /wp-content/plugins/adaptive-images/adaptive-images-script.php file has no access rights and the web server cannot see and run it? It is possible that might be a result of a very strict security policy. Could you check this out for me?

    Cheers,
    Takis

    Themezly

    (@themezly)

    Testing on wamp w10, php 7.2 , all images are 403, no bugs no errors

    Plugin Author Takis Bouyouris

    (@nevma)

    Hello, @themezly,

    Are you sure that there are no errors reported? Can you make sure that the PHP error reporting level is high enough?

    Usually a 403 forbidden error means that the server does not have access rights to the requested resource and, in this case, the resource is /wp-content/plugins/adaptive-images/adaptive-images-script.php, as I mentioned in my last comment. Could this be your case too?

    Cheers,
    Takis

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Some images don’t work after activating plugin’ is closed to new replies.