Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Some images are served from i0.wp.com – BUT site accelerator is not enabled

  • Resolved Vitaliy Lyubezhanin

    (@harikjr88)


    I have woocommerce installed and jetpack (I’m assuming I need jetpack to have some functionality in woocomerce work). BUT everything is pretty much disabled in jetpack.

    HOWEVER, some of my images are getting loaded from https://i0.wp.com/ on this page
    https://themotionbooks.com/shop/personalized-tmb/ – the odd thing is it’s just some images, not all. I actually want to turn this all off. Is there anyway to do that?

    Basically completely bypass anything to do with jetpack site accelerator.

    Thank you for your help.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support bruceallen (a11n)

    (@bruceallen)

    Happiness Engineer

    Hi @harikjr88

    Site Accelerator is used for Tiled Galleries on Jetpack sites, even if the Accelerator module itself is deactivated.

    To use the feature using a Classic Block or Classic Editor plugin independently of the Image CDN, you can follow the guide here to make sure the Image CDN is deactivated and Tiled Galleries are activated.

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    I’m looking at the guide, the interesting thing is that I have ALL modules disabled (as seen here https://imgur.com/a/lqTXi3f).

    I’m also not using Tiled galleries on this page: https://themotionbooks.com/shop/personalized-tmb/ – I’m using WooCommerce for the product gallery.

    So technically I should not be loading ANY images from https://i0.wp.com/ on my site at all, but I have a ton that are coming from there.

    Disabling jetpack completely, does solve the issue, however, I need it to calculate taxes for me so I need to have it activated (which I know is a dumb system here).

    I’m really stuck.

    (I think I linked to a 404 page above, this is the link: https://themotionbooks.com/shop/personalized-tmb/)

    Plugin Support Michelle (a11n)

    (@deathlynotes)

    Hi @harikjr88

    I checked the whole page code and I wasn’t able to find any reference for the CDN addresses https://i0.wp.com/

    Some issues you encounter with your WordPress.com blog or account can be solved by changing your browser settings, refreshing the page, or clearing the browser cache and cookies.

    Here is our support doc that explains how to fix these issues: https://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

    Let me know if you have any questions.

    My best regards,

    Michelle

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    This is what I see when I look at network https://imgur.com/a/PcCTfRB

    I did refresh the page and I’m loading the page with no cache set in chrome.

    I want to mention that I can site accelerator off and also image CDN turned off in jetpack modules – so I’m not sure why my images are loading from the i0.wp.com cdn. If I disable jetpack (and clear cache on my server and browser), it will all be fine. But with jetpack enabled (with the modules disabled), I have the images loading through the CDN.

    Plugin Contributor Dan (a11n)

    (@drawmyface)

    Hi @harikjr88

    I do see some images served from i0.wp.com on https://themotionbooks.com/shop/personalized-tmb/

    You mentioned clearing the cache on your server and browser, but I see you are also using WP Rocket and ‘redic-cache’ plugins. Have you made sure to clear all caches from those plugins too?

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    Yes, I would clear all possible cache. Including cloudflare.

    The thing is, when disabling jetpack and clearing the cache, all images are loaded from my server. When enabling it again (and of course clearing the cache again), I get images that load from the image CDN from wp.com

    Plugin Support Michelle (a11n)

    (@deathlynotes)

    Hi @harikjr88

    Could you temporarily deactivate the Cloudflare and WP Rocket and test the page again, please?

    Something on the cache plugins could be causing the issue of delivering the correct code.

    If you are using minification enabled on WP Rocket or via Autoptimize, for example, could cause the old code to be delivered instead of the new code (without CDN activated). In this case, deactivating Jetpack wouldn’t load the cached code, showing the images with the correct URLs.

    Let us know how it goes!

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    I deactivated Cloudflare, no luck. I deactivated WP ROCKET, no luck as well.

    Keep in mind, that the urls are being re-writtent to include the https://i0.wp.com/ – so I doubt it’s a cacheing plugin. The only things that affects this issues and prevents the url from loading from the CDN – is disabling jetpack.

    BUT again, the site accelerator is off and image can is deactivated (module is off), so it really is a jetpack issue.

    Plugin Support lastsplash (a11n)

    (@lastsplash)

    This is interesting. I tested once, and the images didn’t load from the CDN:

    https://d.pr/CYjaYP

    On other tests, they did.

    In order to test this, the next step is to look for a theme or plugin conflict. The Health Check plugin’s “Troubleshooting Mode” is a good way to do this. It allows you to make changes to your site without them reflecting on the frontend. You can download that plugin here:

    https://wordpress.org/plugins/health-check/

    Once you’ve installed and activated the plugin, you can go to Tools → Site Health:

    * Select the Troubleshooting tab and then click Enable Troubleshooting to automatically disable all plugins and add a new Troubleshooting Menu item in the toolbar at the top of the wp-admin dashboard.
    * From here, you can enable and disable plugins and change the theme for your site, but without affecting normal visitors to your site.

    I recommend starting by testing with a different theme. Please try with a default theme such as “Twenty Twenty” and see if you experience the same issue. If you do not, the issue is with your theme. You will need to reach out to your theme developers for a fix.

    If it isn’t a theme issue, you will need to test for a plugin conflict. Within Health Check, please disable all plugins other than Jetpack and test again. If it works as expected, you know that the issue is with one of your plugins. Please enable your plugins one at a time, testing after each one, until you encounter the issue again. Once you do, you will know which plugin is causing the issue. At that point, you can either leave it disabled or reach out to the developers for a fix

    Let us know what you find out.

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    That is a good idea. However, just by turning off jetpack, the issue is fixed. So jetpack is injecting the url rewrite for the images. Maybe their is a bug in jetpack?

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi @harikjr88,

    just by turning off jetpack, the issue is fixed. So jetpack is injecting the url rewrite for the images. Maybe their is a bug in jetpack?

    By using the Health Check plugin in “Troubleshooting Mode” we want to understand if there is another plugin that’s accidentally triggering the CDN on certain images even if our Site Accelerator features are turned off.

    I can see as well that in the page you shared as an example, some images are served by us (like this one) while others don’t (this one, for example), so that’s strange indeed!

    Let us know how it goes, and if you see anything worth reporting to us.

    Thanks for sorting this out with me!

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    I have the same issue on a dev site here: https://themotionbooks.com/dev2/shop/personalized-tmb/ and the issue is reproduced. This gives more opportunities to troubleshoot without having to use the health plugin.

    The dev site, I excluded it from Cloudflare (and cleared the cache), no changes, some images still loaded from the wp CDN.

    I disabled wp-rocket, so there is no caching. Some images on this page are still getting loaded from the CDN.

    I switch to default theme. Same. The image are loaded from CDN.

    I turned off EWWW Image Optimizer, the images are still loaded form CDN.

    Right when I disable JETPACK (like right away), the images are loaded fine from my server. No issues. Turning on all the other plugins, the images load fine from my server. It’s only jetpack that changes this behavior.

    Activating jetpack (as I need automatic tax calculations and label printing), and boom… images are rewritten to load from the CDN.

    Something in jetpack is causing the images (without my approval) to be loaded from the CDN. I want to mention again, all jetpack modules are confirmed to be off, including site accelerator and Image CDN.

    Looking forward to see what is causing jetpack to still rewrite my image urls.

    Plugin Support Animesh Gaurav

    (@bizanimesh)

    Hi there,

    I checked some images on the dev site, and it appears they are not getting served from Jetpack CDN now: https://d.pr/i/7S1fkL

    Could you please confirm?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.