Support » Plugin: Advanced Custom Fields: Font Awesome Field » Some icons not displaying

Viewing 7 replies - 1 through 7 (of 7 total)
  • Any updates on this? Seems all that’s needed is for the plugin to be updated with the latest FA so that some icons will start to display properly.

    Plugin Author Matt Keys

    (@mattkeys)

    I just checked this out in my development environment and I wasn’t able to reproduce your issue. https://cloudup.com/cv7g2aqMXA7

    Your screenshot is from the backend, are you also seeing problems on the frontend?

    The plugin is designed to automatically use the latest version of FontAwesome utilizing the “Better Font Awesome” library. Perhaps in your environment it is failing to load from BFA and is instead using the fallback version shipped with the plugin? Although it seems odd that the names of the icons are available, and just not the icon itself. You could try updating the font in the fallback in /better-font-awesome-library/lib/fallback-font-awesome/

    You mentioned that you are loading in the font yourself, are you doing this frontend and backend? Maybe try just letting the plugin load the font?

    I first switched my theme first to a default theme, but saw no change. Took out reference to calling the font from the Bootstrap link in my header, no change there either. I replaced the fallback font and css files in /better-font-awesome-library/lib/fallback-font-awesome/ but that didn’t seem to take effect. I just updated all my plugins too.

    It looks like the problem gets resolved in my case if I install the plugin Better Font Awesome (though I don’t plan on using it). It seems like my theme was queuing an older FA stylesheet from somewhere, though I’m still not certain where it’s originating from, so I will be checking on that. It’s not a huge priority right now but I just thought it was an odd bug.

    Plugin Author Matt Keys

    (@mattkeys)

    Thanks for the further debug. I wonder if your browser has cached an older FA for some reason. Checking in another browser might be a good test for that.

    I was originally testing this in Firefox. I went into Chrome and disabled Better Font Awesome, but then the icon(s) disappear again. I re-enabled BFA and the icon reappeared. So something is definitely preventing the most recent FA stylesheet and font files from queuing in my site.

    Hello,

    Got the same issue and once I install the Better Font Awesome plugin, the issue have been solved.

    Thanks !

    -Alex

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Some icons not displaying’ is closed to new replies.