Support » Plugin: Advanced Access Manager » Some hidden items no longer appear in the AAM main panel

  • Resolved philipnormandin

    (@philipnormandin)


    Hello, I would like to raise what may seem to me to be an issue, unless I did not understand how certain functionalities work. When for example I hide access to a backend menu for all roles, there is a symbol that appears indicating that the menu is hidden. It’s a half-covered eye. Until then, everything works. But, later, if I change my mind and want to make visible the menu I have hidden, it is not possible for me to click on the button “Show Menu”, because this menu does not even appear in the list. I noticed that it only happens when I hide something in either “Backend Menu” or “Admin Toolbar”. As soon as the page is reloaded, the items with a red hook or a half-covered eye no longer appear. The only way that I found to remedy this is to click on “Reset AAM Settings”, but it’s counterproductive, since I have to start hiding the menus and other stuff I want to keep hidden. I may not have understood exactly how it all works. Thank you for your attention to this message.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Vasyl Martyniuk

    (@vasyltech)

    @philipnormandin,

    Happy New Year. That is a good catch. In AAM 5.5 I had to change a bit the way Admin Menu is managed in order to cover more edge cases. However I did not take in consideration to show the full list of Admin Menu items when Default Access Settings have been set.

    You can get the dev version from here https://downloads.wordpress.org/plugin/advanced-access-manager.zip. This should solve the problem.

    Thank you,
    Vasyl

    @vasyltech

    Happy New Year too, thank you! You’re really good, the dev version has solved the problem.

    Thank you so much!

    I had issues with backend menus items disappearing too, the dev version also fixed it.

    Thanks!

    Hey, Vasyl,

    I found this post because I thought it was the same issue I’m having, however I’ve installed the new dev version and I still have my issue.

    For me it’s this:

    – I created a new role, and was able to fully customise the backend menu for that role
    – Later, I installed Gravity Forms and found that my new user role was unable to access the GF backend menu
    – When I go into AAM settings to try and enable it, I don’t see ‘Forms’ in the backend menu list, for any role
    – If I go into User management, I can see ‘Forms’ for all users

    Any ideas?

    Thanks,

    Henry

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.