Support » Plugin: Advanced Custom Fields: Font Awesome Field » Some fonts not available

  • Resolved DavidB722

    (@davidb722)


    Hi,

    I’m noticing that some fonts are not available, specifically from the “Brand Icons” section of FontAwesome 5.

    Steps to reproduce: Add a new FontAwesome field type, and search for either “magento” or “vuejs”. Neither return results, nor does either appear in the dropdown. Note that these both are available fonts in the current version of FontAwesome: https://fontawesome.com/cheatsheet#use

    I’m enqueing FontAwesome in the theme, not using the plugin. I can use these icons elsewhere in the theme without issue, which would seem to rule out an issue with the fonts not being enqueued properly.

    Versions in the stack:
    WordPress 4.9.8
    ACF Pro 5.7.1
    ACF FontAwesome 3.0.0-beta2
    FontAwesome Free 5.2.0

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    Hi David,

    I just took a look in my development environment and I see these two fonts available. (screenshot: https://cloudup.com/coX37VAVN1a )

    Assuming that you have FA 5.x enabled in the plugin settings, I am not sure why these wouldn’t show up for you. The plugin does cache the available fonts, so maybe your site just hasn’t updated this cache yet for some reason.

    It should check once daily for new versions of the font. You should be able to force the plugin to get the font again by temporarily switching to FA 4.x and then back to 5.x.

    Let me know if they start showing up for you.

    Thanks for the response, Matt!

    This is officially user error 🙂 I completely missed the settings toggle to switch between v4 and v5. Resolved.

    • This reply was modified 1 year, 3 months ago by DavidB722.
    Plugin Author Matt Keys

    (@mattkeys)

    Ah okay thanks, you may not be the only one to miss that screen. I’ll think about ways to call attention to it.

    Where are plugin settings?

    Plugin Author Matt Keys

    (@mattkeys)

    This currently only applies to the 3.0 Beta’s, there is a settings screen in the admin area, go to Custom Fields > FontAwesome Settings. Putting a link to it in the area you showed a screenshot of would be a good idea.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Some fonts not available’ is closed to new replies.