Support » Plugin: CC Child Pages » Some Excluding Pages Appearing in Widget

  • Hi, Awesome plugin.

    I have a website that has almost 400 documents that are parent child related. I set a widget up to only display siblings by having the “show sibling pages” checked and I also listed all parent page id in the “Exclude” field. The desired result is when I select a parent page the widget should be blank and when I select a child it’s sibling pages are listed in the widget. This almost works with one anomaly.

    When I go to any ‘parent’ page, the children of the a different parent are listed. Funny thing is it’s the same parent/child displayed regardless of the parent page I go to. FYI – the listed child pages are under the first parent page and it’s the one with the lowest ID, in the list of pages. I have verified the parent ID is in the list of pages to be excluded and I have check to see that no shortcut was used in the parent page except [child_pages orderby=”date” ].

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author caterhamcomputing

    (@caterhamcomputing)

    Hi.

    That sounds odd … I will try and recreate the issue.

    Thread Starter orangeloon

    (@orangeloon)

    Any luck recreating the issue?

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    I’ve been playing around with the widget and haven’t found any problems as such … however, one thing that has occurred to me is that if you have left the depth setting as 0 it may be displaying children of siblings that have been excluded.

    Try setting the depth to 1 and let me know if it resolves the issue.

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    I’ve been looking into the issue and can’t seem to recreate your issue exactly … can you copy and paste the contents of the Exclude field so that I can see if there is some issue there?

    Does setting the depth to 1 give a more useable output?

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    I have just released a new update to the plugin which adds an ‘Exclude Tree’ field to the widget. This excludes not only the pages in the list, but also their children.

    If you copy your list of excluded pages from Exclude to Exclude Tree I think everything should work as you want.

    Please let me know if this solves your problem or not, and if not it would be helpful if you could specify copy and paste the values in the Exclude/Exclude Tree lists to this thread (and summarise the other values).

    Thread Starter orangeloon

    (@orangeloon)

    I updated the plug but the problem still exist.

    Exclude List: 3784,3742,3433,3,17,53,54,55,56,57,60,89,280,345,355,364,365,410,420,3248,3283,3284,3433,63,145,445,454,447,448,460,570,644,571,605,668,697,738,752,805,764,747,836,870,871,900,882,933,960,1128,1129,1149,1198,1236,1237,1266,1308,1320,1347,1348,1401,1365,1509,1413,1414,1455,1491,1542,1567,1608,1662,1629,1615,2845,2869,2846,2884,2932,3021,3045,2933,2956,2996,3066,3067,3087,3119,3137,3164,3165,3169,3191

    I don’t use the Exclude Tree.

    Thread Starter orangeloon

    (@orangeloon)

    Quick update: I noticed that when I add a new page that is not excluded and not tied to a parent, all the exclusions work perfect and only the new page appears – as expected. Once I put the new page in the exclude list, the few non-related children appear. BTW: the ones that appear are always the full list (4) of the first parent in the menu.

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    Please cut and paste the excluded list to the new Exclude Tree field. The pages in the list will no longer show, and their child pages will also not appear spuriously.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Some Excluding Pages Appearing in Widget’ is closed to new replies.