Support » Plugin: PhastPress » some error 404 file notfound

  • Resolved touficmamdouh

    (@touficmamdouh)


    some error 404 file notfound and install wp supercache to
    screenshot :https://ibb.co/SxLtfXy

    :path
    /wp-content/plugins/phastpress/phast.php/__p__.js?service=bundler&p=157911764&f=00uggcf%3N%2S%2Soebamr
    .dn%2Sjc-vapyhqrf%2Spff%2Sqvfg%2Soybpx-yvoenel%2Sfglyr-egy.zva.pff&v&g=o8p031145232r3rs
    /wp-content/plugins/phastpress/phast.php/__p__.js?service=bundler&p=2456437564&f=00uggcf%3N%2S%2Soebamr
    .dn%2Sjc-pbagrag%2Scyhtvaf%2Snqq-fbpvny-funer-ohggbaf%2Schoyvp%2Swf%2Snqq-fbpvny-funer-ohggbaf-cyhtva-choyvp
    .wf&w=1&g=2p2n9ps388qq9rp8&f=11qlnzne-pbagnpgf%2Swf%2Spbagnpg-sbez.wf&w=1&g=67o2q9169nq429n0&f=11erifyvqre
    %2Schoyvp%2Snffrgf%2Swf%2Swdhrel.gurzrchapu.eribyhgvba.zva.wf&w=1&g=2q035o7q5523p525&f=2ngbbyf.zva.wf
    &w=1&g=09ss3s11s1132nn7&f=11fvgrcerff-zhygvyvathny-pzf%2Serf%2Swf%2Spbbxvrf%2Synathntr-pbbxvr.wf&w=1
    &g=pq134ps0565npsp4&f=1mwdhrel.pbbxvr.wf&w=1&g=r3r6s5641p4n330s&f=11jbbpbzzrepr-zhygvyvathny%2Serf%2Swf
    %2Spneg_jvqtrg.zva.wf&w=1&g=93p0p0897107858o&f=1ksebag-fpevcgf.zva.wf&w=1&g=nnq73q18p13q01n9&f=0yvapyhqrf
    %2Swf%2Swdhrel%2Swdhrel-zvtengr.zva.wf&w=1&g=n75ssrr1po0r65qq&f=1n.wf&w=1&g=6s4o704s59rr843n

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Albert Peschar

    (@kiboit)

    Hi Toufic,

    Thanks for trying out PhastPress.

    Your hosting is using caching (with the Varnish caching server). This seems to cause the query string (the part of the URL after ?) to be ignored, so that URLs like this don’t work:

    https://bronze.qa/wp-content/plugins/phastpress/phast.php/__p__.js?service=bundler&p=157911764&f=00uggcf%3N%2S%2Soebamr.dn%2Sjc-vapyhqrf%2Spff%2Sqvfg%2Soybpx-yvoenel%2Sfglyr-egy.zva.pff&v&g=o8p031145232r3rs

    Unfortunately, this is required for PhastPress. You can ask your hosting provider to change their configuration so that query strings are not ignored, or disable the “Load scripts asynchronously” option in PhastPress.

    The “Specify a cache validator” error is also due to your server configuration. PhastPress sends the required ETag header by default, but it is removed by your server before the response is sent to the browser.

    –Albert

    The “Specify a cache validator” error is also due to your server configuration. PhastPress sends the required ETag header by default, but it is removed by your server before the response is sent to the browser.

    how can fix that ??

    Plugin Author Albert Peschar

    (@kiboit)

    Hi Toufic,

    Thanks for your review!

    Probably it is caused either by a rule in your .htaccess file, or by the configuration of the Varnish caching server.

    To verify that the problem is with your hosting, and not with PhastPress or another plugin:

    Please create a file called etag.php on your server with the following contents:

    <?php header('ETag: "Hello"'); echo date('r'), "\n"; ?>

    Check the URL in https://websniffer.cc and see if the ETag header is added correctly (example).

    Please also post the URL to etag.php here.

    If the ETag header is missing, then the problem is somewhere in your hosting configuration. In that case, you can post your .htaccess file to http://dpaste.com and share the link here. I will check if it’s possible to fix the issue there.

    –Albert

    Is there a filter to change

    https://bronze.qa/wp-content/plugins/phastpress/phast.php/__p__.js?service=bundler&p=157911764&f=00uggcf%3N%2S%2Soebamr.dn%2Sjc-vapyhqrf%2Spff%2Sqvfg%2Soybpx-yvoenel%2Sfglyr-egy.zva.pff&v&g=o8p031145232r3rs

    to something like

    https://bronze.qa/assets/pretty/urls/

    and then rewrite rules can call in the correct path?

    Plugin Author Albert Peschar

    (@kiboit)

    Amibe,

    No, unfortunately not. You will have to make the path in wp-content accessible in order for PhastPress to work.

    Please create a new topic if you have further questions. (So that the original topic owner doesn’t get notifications.)

    –Albert

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘some error 404 file notfound’ is closed to new replies.