Support » Fixing WordPress » some directories seem to be missing in my installation?

  • I’ve searched the forums, but can’t seem to find anything about what appears to be a simple problem. Also searched the docs section.

    I seem to be missing a subdirectory called “category” (under root wordpress directory) and I also noticed I don’t have an “upload” directory under my wp-content directory.

    Was I supposed to have created these? Or did I screw something up installation?

    Site is located at:
    If you try to click on a category (only one now), you’ll get a 404 page error. subdirectory “category” is not there now… so no way to get to this page.

    thanks for any help. you all have done a great job with this project.

    ps — also just noticed that the one static page i created is also a 404 error when you click on it in the navigation “what is it” at the top of the page. I’ve gone in and checked chmods, etc. I don’t see any problems and they all seem to be inline with the wordpress permissions settings.


Viewing 11 replies - 1 through 11 (of 11 total)
  • No “categories” directory needs to be created, Kristie. You, however have to create an “upload” directory and set its permissions (probably to 777). Also, make sure your htaccess file is writeable.

    Categories, by the way, are managed in your admin panel, in Manage -> Categories.

    There is no “category” subfolder.

    When you install wp, you will see three folders: wp-admin, wp-content, and wp-includes. There will be a bunch of .php files in the root, and each of the listed folders will include other files, and in the case of wp-content, folders for themes and plugins.

    That’s it….

    So have you created any categories etc?

    (Love the site idea btw, we have a brit – but no birds *sigh*)

    [Beat me, neon! Hey, you don’t happen to be messing with eSyndiCat too, do you?]

    What should my chmod be for the htaccess file? (i have it at 664 now…)

    Also… On my homepage I renamed the “uncategorized” category to “miscellaneous”… But if you look at the URL for that category, it’s:

    So where is it getting this “category” link? Is this maybe something in my theme (Blix, btw, which I forgot to mention).


    Um. Yeah, I noticed it was blix, and I have to tell you up front that about it I know only that it’s very very painful to deal with….

    The short-form (“misc”) is probably something with the theme, because that sort of thing never happens on my installs. Do you have any posts in any of the cats?

    .htaccess: chmod to 777, go to the permalinks page in the admin section, set and update the permalinks, chmod .htaccess to 644.

    The category link is set by permalinks, which looks like you are trying to implement. Basically, that creates easy url addresses like the one you see, instead of etc. Your htaccess file permission should be at least 666 to be writeable.

    vkaryl beat me.

    P.S. vkaryl, “Hey, you don’t happen to be messing with eSyndiCat too, do you?” – nope, no such luck. 🙂 (not yet at least, lol)

    crap, i figured because it was featured that it was a safe bet (because I had already tried another and trashed it!!)

    I did the short form misc, entered it in myself because I didn’t see the point to using the whole thing?

    Where is it getting the “category” directory to put in the URL?

    i’m going to mess with htaccess. Thanks.


    I switched the permalinks to the standard. I just thought the dates thing would be helpful. But trashed it. That got the category links working…

    I’m pretty sure that did the whole thing. Thanks for the very quick response.

    Well, things get featured around here for many reasons, not always that they’re really the best there is.

    I misunderstood about the “misc”…. so in that case it’s NOT the theme doing something odd! Sorry!

    It’s getting the “category” part from the permalink setup. Y’know, if I were you, I’d not mess with the permalinks until you’ve got the whole thing working, set up how you like it, and got comfortable with it….

    sounds great, thanks again. it’s been a pleasure and sorry for the double post!

    Well, let us know how it goes, and post back if you need something else! Like I said, great site, get it going and I’ll be bookmarking it.

    I had the same problem.
    I followed advice, changes .htaccess to 777.
    Went to admin, permalinks, set to default.
    Went back to .htaccess and reset to 666.
    I had tried option to in permalink change, and it
    did correct the problem, but it deleted the rest
    of the right navigation panel. So I tried the default on and everything is working fine so far as I have tested.

    Thank you for the help. It is simple when you know what to do.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘some directories seem to be missing in my installation?’ is closed to new replies.