WordPress.org

Forums

Decode
[resolved] Some decode images break in child theme (4 posts)

  1. Steven Jay Cohen
    Member
    Posted 1 year ago #

    When I was testing the Kindle fix, I found something else.

    On IE 7 and the Kindle, the Sidebar Menu icon (the 3 bars), and the Soundcloud icon both break.

    Using inspect element, I see the following:

    Working images:
    <image src="http://www.domain.com/wp-content/themes/decode/images/Twitter.png">

    Working images show DECODE as the theme.

    Broken images:
    <image src="http://www.stevenjaycohen.com/wp-content/themes/child/images/Soundcloud.png">

    and

    <image src="http://www.stevenjaycohen.com/wp-content/themes/child/images/menu.png">

    Broken images show CHILD as the theme.

    I don't know why this works in most browsers. WordPress must be doing some kind of redirect. But, older browsers don't like it. And, it seems that most of your images show DECODE and not CHILD. So, I am assuming this is an easy fix on your end.

    Let me know if I can be of any other help.

    Steven

  2. Steven Jay Cohen
    Member
    Posted 1 year ago #

    Temporary workaround: add a symbolic link to the child theme's directory:
    ln -s ../decode/images images

  3. Scott Smith
    Member
    Theme Author

    Posted 1 year ago #

    I'm not going to touch this for now because I reworked the SVG fallback in Decode 2.9 (which is in the queue for review). Thanks for the heads up, but I think the new fallback will work!

    Also, thanks for all your help weeding out bugs. :)

  4. Steven Jay Cohen
    Member
    Posted 1 year ago #

    You're welcome. Since you are sharing Decode freely (no premium version), I feel that helping debug is the least that I could do.

    So, anyone using a Child Theme with decode should implement my workaround (above) until v2.9 is released?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic