WordPress.org

Forums

Some custom scripts not found after upgrade to 3.0 (2 posts)

  1. ericr23
    Member
    Posted 5 years ago #

    I upgraded to 3.0 manually. Everything in WordPress itself is working fine. But I run a script in the sidebar to do a custom query: a script to list "selected" posts on the home page, and one to list "latest" posts on a single-post page. The first one works, and the second doesn't. According to Safari's activity monitor, it is not a coding issue but simply that the second script is not found (they are both loaded via Ajax). If I switch the scripts' names, the results are reversed, i.e., the single-post script works (though listing "selected" instead of "latest" posts, and the home page one doesn't.

    What inside the file would prevent it from being found? Note that yesterday, before the upgrade to 3.0, they were all working fine. I have reset permalinks, recopied the scripts, restarted Apache, restarted the whole server.

    WordPress resides in a subdirectory of the web site. Both scripts reside in that subdirectory.

  2. ericr23
    Member
    Posted 5 years ago #

    Solved! The one script that worked turned out to have the byte-order mark at the start of the file, and the others did not. (All are UTF-8.) Adding it fixed the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic