Support » Plugin: WP BrowserUpdate » Some Buttons aren’t correctly displayed after script editing

  • Resolved rudimentaer

    (@rudimentaer)


    After entering this code

    echo '<script type="text/javascript">
    var $buoop = {text: "Ihr Browser ist leider veraltet und stellt die Seite daher nicht korrekt dar. Bitte {up_but} oder {ignore_but}",

    Instead of the buttons this will appear:
    id=”buorgul” role=”button” tabindex=”0″ href=”https://browser-update.org/update-browser.html?force_outdated=true#3.2.14:mydomain.at&#8221; target=”_blank” rel=”noopener”

    same with {ignore_but}
    {brow_name} however works fine (and text also)

    Tried around for like an hour…can’t figure out were the mistake is.
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Steini

    (@macsteini)

    Will have a look. Any sample URL you can provide?

    Thread Starter rudimentaer

    (@rudimentaer)

    Thank you, yes here it is:

    Plugin Author Steini

    (@macsteini)

    ???

    Thread Starter rudimentaer

    (@rudimentaer)

    Oh? Wasn’t it included?
    URL

    Plugin Author Steini

    (@macsteini)

    According to the documentation you want to mask the code like this:

        text: "",
        // eigener Banchrichtigungstext (html)
        // Der Platzhalter {brow_name} wird mit dem Browsernamen ersetzt, {up_but} mit dem Inhalt des "Update"-Link-tags und {ignore_but} mit dem Inhalt des "Ignorieren"-Links.
        // Beispiel: Ihr Browser {brow_name}, ist zu alt: <a{up_but}>Aktualisieren</a> oder <a{ignore_but}>Ignorieren</a>.

    If the above looks broken, check this out: http://browser-update.org/customize.html

    Thread Starter rudimentaer

    (@rudimentaer)

    Thank you Marco!
    Strange, Firefox show that line like this:
    // Beispiel: Ihr Browser {brow_name}, ist zu alt: <a{up_but}>Aktualisieren oder <a{ignore_but}>Ignorieren.

    So I used it wrong.
    Thanks for clearing it up! Danke 😉
    Especially for the very fast responsive! Very much appreciated!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Some Buttons aren’t correctly displayed after script editing’ is closed to new replies.