Support » Plugin: Inline Related Posts » Some bugs in your plugin

  • Hi, I started to use your plugin yesterday and I like it. However, I faced some problems while using it:

    1 – I noticed that there is an extra space after my “Read also” text. And I didn’t add this space. So I guess, it’s from your side. Can you fix it, please? Here is a screenshot – https://c.radikal.ru/c28/2105/cc/1da3e32702c1.jpg

    2 – In “minimalistic” style, when I try to change box background color for orange, violet and others, then for some reason it always stays white. It’s seen in a previous screenshot. Other options work fine. Why this option doesn’t work in my case?

    3 – I noticed that links are always underlined. Is it possible somehow to make then normal and underline them only in hover? And also I noticed, that my text “Read also” is underlined too in hover. Here is a screenshot – https://d.radikal.ru/d19/2105/11/9ef31ca329f7.jpg
    Is it possible to remove this underline under text and to make this text non-clickable?

    4 – On my website I have different margin-top and margin-bottom between paragraphs for different devices. 20px for mobile phones and tablet, and 30px for PC. And because of that I can’t make a suitable size for all devices in your “CSS margin-top” and “CSS margin-bottom” option. So is it possible to enter different margins for different screen widths?

    And also I wonder: why didn’t you make an ability to add more than 1 related post in 1 place? I understand that you have a PRO version where people can add unlimited related posts, but still 1 by 1. I guess, that you don’t want people to add 3 by 3 related posts for free, and it’s understandable. However, for me personally it’s better to have at least 1 placement for 3 related posts, then 3 by 1. Here is a good implementation of how it should look like in my opinion – https://c.radikal.ru/c20/2105/cd/2135a2a11d82.jpg

    And btw, I attached one of my posts in case it’s needed.

    Thanks in advance for an answer!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author IntellyWP

    (@intellywp)

    Hello

    1. this space is to separate the cta from the post title
    2. could you please record a video? i tested successfully this feature
    3. please go to appearance > customize > additional css and paste

    div[style="clear:both; margin-top:0em; margin-bottom:1em;"] a .postTitle {
    	text-decoration:none !important;
    }
    
    div[style="clear:both; margin-top:0em; margin-bottom:1em;"] a:hover .postTitle {
    	text-decoration:underline !important;
    }

    4 and 5. Unfortunately these features are not still available, we will keep it in mind for a next version

    Have a nice day

    Thread Starter George

    (@giorgos93)

    Thanks for the answer!

    About #3 — I think you wanted me to insert something like that:

    .postTitle {
    text-decoration:none !important;
    }

    .postTitle a:hover {
    text-decoration:underline !important;
    }

    Unfortunately, it doesn’t remove underline, and now I know why. In /intelly-related-posts/assets/templates/styles.html there is a piece of code:

    .{utemplate} .postTitle {
    color:{postTitleColor};
    text-decoration: underline!important;
    font-size: 16px;
    }

    I had to remove !important in your text-decoration: underline!important; so I could remove underline. I think you need to remove !important from your side in future update, so users can change it in style.css. Now I can’t, because your !important overrides mine 🙂

    About #2: I think there is the same problem as above, but at this time you have to ADD !important somewhere in box-backround color. Not sure though.

    Plugin Author IntellyWP

    (@intellywp)

    Hello

    you can remove the !important css rule from this file /intelly-related-posts/assets/templates/styles.html

    Unfortunately i’m not able to reproduce this issue, i changed successfully the colors of related posts

    which version of our plugin have you installed?

    Thank you

    Thread Starter George

    (@giorgos93)

    I use the last version (v.3.0.2). But to be honest, this box background color doesn’t bother me, because standart white color looks good on my website.

    And I’ve already removed !important in your plugin’s code, thank you.

    The last thing that I want to ask you to help me with, is the cta text. Can I unlink this text somehow? I don’t like it to be underlined in hover together with related post link, so I want it to be a simple text, not a link. Is it possible to do?

    Thanks in advance!

    Plugin Author IntellyWP

    (@intellywp)

    Hello

    you can edit the following file

    /intelly-related-posts/assets/templates/styles.html

    and insert, after

    .{utemplate} .postTitle {
    color:{postTitleColor};
    text-decoration: none!important;
    font-size: 16px;
    }

    the following code

    .{utemplate} .postTitle:hover {
    text-decoration: none!important;
    }`

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Some bugs in your plugin’ is closed to new replies.