Support » Plugin: Greenshift - animation and page builder blocks » Some BUGS in the “VideoBox” block

  • Resolved acelerawp

    (@acelerawp)


    Hi WPSoul, I hope You are doing great.

    Here are some BUGS I have found in the “VideoBox” block.

    1 – This BUG in the “VideoBox” block happens when we use YouTube videos and Self-Hosted videos:

    The “AutoPlay” setting gets “Overwritten” under the hood by the “Mute” setting, whatever setting we choose for the “Mute” option ( Enable or Disable) and NO Matter which setting we apply to “AutoPlay” ( Enable or Disable). Even the “Autoplay” label is replaced by the “Mute” label. Below some STEPS to reproduce the BUG:

    a – Add the “VideoBox” block and insert the URL from any YouTube video
    b – Enable the “Autoplay” option
    c – Enable the “Overly or Lightbox” option. In this point You will see how the “Autoplay” label is replaced by the “Mute” label
    d – Disable the “Mute” option and now Update / Save the settings
    e – Now go to the Front-End and Play the video. You will see that “Autoplay” is Not working, even when in the backend the “AutoPlay” option is “Enabled”. So apparently “under the hood” this setting gets “Overwritten” in the database by the “Mute” setting we have set to “Disable”. Also, if we set the “Mute” setting to “Enable”, the “AutoPlay” is “under the hood” overwritten with “Enable” no matter what setting You have set for the “AutoPlay”.

    2 – This second BUG in the “VideoBox” block happens when we use Self-Hosted videos:

    When using “Self-Hosted” videos and we “Enable” the “Overly or Lightbox” option, then in the front-end You will NOT see the Preview Image of the video, instead you will only see a Solid Color NO matter the opacity value you use in the “Overlay Colors” settings. Even if You set the opacity to 0 / ZERO You will Not see the preview image. So, in order to see in the front-end the preview image of the “Self-Hosted” video You have to Disable the “Overly or Lightbox” option. However, You can start playing the video in the front-end if You make Click over the Solid Color.

    3 – This third BUG only happens when we use Vimeo videos:

    In order to see the Video in the front-end, You have to Enable the “Overly or Lightbox” option. If you Don’t Enable the “Overly or Lightbox” option, then in the front-end You will Not see the video.

    These BUGS are Not easy to describe only with words, so just in case You are Not able to reproduce these Issues from Your end or something is Not clear in my explanations, I can give you access to my Testing website with temporary Login Details so that you can check the Pages where I reproduce all these issues. Only let me know if you need it.

    All the Best,
    Miguel

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter acelerawp

    (@acelerawp)

    Only to clarify one little detail that may lead to confusion in the “Second BUG” described above, when using “Self-Hosted” videos:

    When I Say “Preview Image” of the video, this does NOT mean I’m using a “Poster image” in General –> Video settings. NO, I’m NOT using any poster image. When I Say “Preview Image” of the video I’m referring to the default Frame, Image or Whatever thing is shown by default in the “front-end” before we make Click over the Video area.

    Plugin Author wpsoul

    (@wpsoul)

    1. It’s not bug. Autoplay with sound is not allowed in most of browsers, so, it’s always muted

    2. I can’t reproduce. Image is visible https://monosnap.com/file/02T86BdB7vuaDnI1jkCVEcDHnJCAji Please, send link on page with issue

    3. It’s fixed in update

    Thread Starter acelerawp

    (@acelerawp)

    Hi WPSoul,

    I have created Two short Videos so that You can easily see what is happening. Let’s begin:

    1 – BUG description: In the front-end You will only see a “Solid Color” NO matter the opacity value you use in the “Overlay Colors” settings. This BUG happens when using “Self-Hosted” videos and we “Enable” the “Overly or Lightbox” option. Additionally in the Video I will show You a New Issue because it is very difficult to describe it with words.

    In this Video I show You how to reproduce the Two Bugs, STEP by STEP. Here the link –> https://youtu.be/jcHa2Jm1UE4

    In case You need, here the Page URL –> https://playgroundwp.xyz/using-self-hosted-video-greenshift-bug-in-videobox/

    Probably You were Not able to reproduce the BUG because in your example you were using a “Poster Image”. Like you saw in the Video, I’m NOT using Poster image.

    2 – Issue description: When using “YouTube” videos and we “Enable” the “Overly or Lightbox” option, the user in the Front-End has to make Two clicks to start reproducing the video. However, the YouTube video should Start Playing with only One Click even if we have Enabled the “Overly or Lightbox” option.

    In this video I show You the Issue in “Greenshift” and how a competitor Plugin is able to Start Playing the YouTube video only with One Click using a similar Lightbox/Popup setting. Here the link –> https://youtu.be/Kez-6PnFU3E

    In case You need, I can give You access to my Testing website with temporary Login Details so that You can check in the Back-End the Pages where I reproduce all these issues. Only let me know if you need it.

    Plugin Author wpsoul

    (@wpsoul)

    1. You need to add also overlay image. Otherwise, there is nothing to show except color

    2. It’s correct. Unfortunately this is the only possible way to prevent loading youtube scripts on page loading. Otherwise, scripts will be loaded and web vitals score will drop near 30 points. If you don’t care about speed and web vitals score, then, don’t use overlay option

    Thread Starter acelerawp

    (@acelerawp)

    Hi my friend WPSoul,

    Please, check this link I have prepared for You on my testing website, so that You can verify how the “Video Popup” block from the competitor “Kadence Blocks” plugin only needs “One Single Click” to open the video Popup and Star Playing the video while also preventing loading YouTube scripts on page loading using Overly and Lightbox. Please, make click over the video in the URL below: 

    https://playgroundwp.xyz/kadence-video-popup/

    Like You has verified in the page link above, in “Kadence Blocks” Video Popup block, only “One Click” is Needed to open the Video Popup and Start Playing the video “automatically” while also preventing loading YouTube scripts on page loading. All with only “One Click”.

    In Greenshift after the user Clicks over the “VideoBox” in the front-end, a Popup with Overlay is displayed, BUT the video inside the Popup is NOT starting playing automatically, so You need to make a Second Click in order to start playing the video. This is the issue.

    It would be great if You reduce from “Two Clicks” to only “One Click” when using YouTube video + “Overlay or Lightbox” ENABLED. Just like it is already accomplished in Kadence “Video Popup” block.

    All the Best.

    • This reply was modified 1 year, 6 months ago by acelerawp. Reason: put the page link on a new line
    Thread Starter acelerawp

    (@acelerawp)

    Hi WPSoul, related to my reply above, I have just discovered that in “Firefox” and “Microsoft Edge”, the “VideoBox” using YouTube + “Overlay or Lightbox” + “Lightbox” All ENABLED, AFTER, after the Popup/Lightbox is Opened, the Video inside the Popup/Lightbox start playing automatically, which is good. BUT in Google Chrome or any other Chromium based browser, the video is NOT start playing automatically after the Popup/Lightbox is opened, forcing us to make a Second Click.

    I hope my explanation was clear enough 🙂

    • This reply was modified 1 year, 6 months ago by acelerawp.
    Thread Starter acelerawp

    (@acelerawp)

    Hi,

    This is Not related to the Last Two replies above. This is other BUG. I will show You in the Video below how to reproduce this BUG with Selft-Hosted + “Poster Image” + ALL, ALL the LightBox options ENABLED. Here the link:

    Here the Page link in case You need –> https://playgroundwp.xyz/using-self-hosted-video-greenshift-bug-in-videobox/

    • This reply was modified 1 year, 6 months ago by acelerawp. Reason: add new information
    Plugin Author wpsoul

    (@wpsoul)

    This should be fixed now in update

    Thread Starter acelerawp

    (@acelerawp)

    Thank You WPSoul, the little bugs has been fixed.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Some BUGS in the “VideoBox” block’ is closed to new replies.