Support » Plugin: Leira Letter Avatar » Some Avatars are ‘Missed’

  • Resolved eduardochaves

    (@eduardochaves)


    Hi,

    I don’t know how and why but, some avatars on my website comments are ‘missing’. When I started using this plugin was all good, but one day I entered in my website and some avatars was like this: https://prnt.sc/10gnjqc. I already tried to fix this in many ways but I’m not having success.
    My website is progress yet but you can see 2 test posts I have and you can try to comment too and see what happens: https://fotografandooficial.com.br/bem-vindo/#comments
    So i’m asking for help cause I don’t know what to do anymore to fix this.

    PS.: Some avatars are showing because the email of these has the avatar on “Gravatar”. And there are some others that are showing with the letters, but those are with older configs (like one that just has 1 letter and a blue background and it doesn’t change even if I change the config in the plugin’s config)

    Thanks,
    Eduardo Chaves

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ariel

    (@arielhr1987)

    Hi @eduardochaves

    While checking your website I noticed that you are using WPDiscuz.
    All broken avatar images in your comments look like this:

    <img alt="Eduardo Chaves" src="https://fotografandooficial.com.br/wp-content/uploads/wpdiscuz/cache/gravatars/a87ff679a2f3e71d9181a67b7542122c.gif" srcset="https://fotografandooficial.com.br/wp-content/uploads/wpdiscuz/cache/gravatars/a87ff679a2f3e71d9181a67b7542122c.gif 2x" class="avatar avatar-64 photo" height="64" width="64" itemprop="image">

    As you can see the image is pointing to an url (like https://fotografandooficial.com.br/wp-content/uploads/wpdiscuz/cache/gravatars/a87ff679a2f3e71d9181a67b7542122c.gif). which is not related to leira letter avatar. Usually leira letter avatar url should look like this: https://fotografandooficial.com.br/wp-content/uploads/letter-avatar/397bb03a362ff38528e707434cfd4305.svg

    Do you have a cache plugin enabled?
    Check your wpdiscuz settings or contact the developers to check what is that image they are caching.

    Kind regards

    Thread Starter eduardochaves

    (@eduardochaves)

    Thanks Ariel,
    And sorry for taking so long to reply you…

    So, yes I have some cache plugins enabled.
    I already checked the wpDiscuz settings and as I see there isn’t anything I can do to fix this in the plugin’s settings.
    And I just contacted the wpDiscuz on wordpress plugin’s forum and I’m now waiting for their answer. When they reply me I’ll come back here to say the feedback about what happened.

    Thanks,
    Eduardo Chaves

    Thread Starter eduardochaves

    (@eduardochaves)

    So…

    They replied me, and the problem is already resolved!
    It was a gravatar caching that was enabled on wpDiscuz config. and I didn’t know about this.
    And thanks anyway for helping me.

    Thanks,
    Eduardo Chaves

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Some Avatars are ‘Missed’’ is closed to new replies.