Support » Plugin: Easy Social » Solving deprecated notice/s

  • Hello,

    I have been using this plugin for years!

    Recently, came across a deprecated notice, when WP debug log is turned on.

    PHP Notice: The called constructor method for WP_Widget in socialIcons is deprecated since version 4.3.0!

    To solve this, please edit the file easy-social-widget.php and change the line (number 3 as of this writing) that starts with parent::WP_Widget (inside function socianIcons()) to parent::__construct. When you do this, you’ll be presented with another PHP notice as follows…

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP

    To fix this, edit the same file and change the line (number 2 as of this writing), from function socialIcons() { to function __construct() {.

    Hope this helps someone!

    https://wordpress.org/plugins/easy-social-media/

  • The topic ‘Solving deprecated notice/s’ is closed to new replies.