Support » Fixing WordPress » Solved My “Insert Image into Post” Blank Popup Problem – Sharing

  • I hope this is the right place to share this.

    I have 3 WordPress driven sites that I have upgraded to WordPress 2.5 this week, and I had the same problem that others had, that when I clicked the insert into post button on the media manager, the popup window went white, and stayed there and nothing else happened.

    Having tried all the solutions, and having found it worked now and again seemingly randomly, tonight I discovered a scenario I could reproduce and a fix.

    Typically I have Firefox open on my main website, and then I open one of the other sites in another tab. When the site I am editing is on the second tab (haven’t tested further than that) “Insert Image into Post” produces a white popup screen, if I close the first tab I can then insert images perfectly.

    Why this would solve it, I don’t know, and this may just be a quirk of my system, but I wanted to share in case its not just me!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Yups… i have the same problem.
    dont know why? but maybe next time there’s an update to fix this bug. Hope.

    the same problem also when i try to insert a link into my post.

    Same problem here when I try to insert images. I don’t like this new flash gallery at all…

    I just find the solutions for this bugs. It takes 4 hours for me to search in google. But worthed. Finally i found it.
    You guys can give it a try. I post the solution in my blog :

    @reviewabc: I’m not sure what your motives are, but there are a few things wrong with them. 1. You don’t simply list the solution here which makes me think you’re just looking for some traffic (which you got).

    2. You didn’t link to any post, just the main blog. So now I have to search through all your posts looking for the solution. This further makes me think you’re only looking for traffic.

    3. The attached file can’t be downloaded.

    So with all this being said.

    Could someone please help me. I have three blogs, all upgraded at the same time. 2 don’t work, one does. I’ve even hit the deactivate all plugins button.

    WP 2.5 is really turning out to be a pain in the butt.

    Thanks TeddyBare!
    I was experiencing exactely the same problem and your ‘solution’ works perfectly.

    Oh man, this is great! It IS because of the tabs. For me, WordPress had to be the ONLY tab.

    Now we have a temp “fix.” (THANK YOU THANK YOU THANK YOU!)

    But I hope someone will come up with a way to let us upload images while we have other tabs open…

    Thank you, TeddyBare 😀
    That really works.

    Having problems uploading images; problem started on Monday. Using WP 2.3.3 as my hosting network hasn’t yet made WP 2.5 available. Can’t upload images and I’ve tried several suggestions including turning off plug ins, clearing cache in Safari (running iMac, 10.5.2), installing latest Flash player and downloading Firefox and trying that. None of it works. What gives? Blog’s at a standstill because I can’t upload photos to the posts. Help!?

    Ha! Life is good again. Thanks for the fix, works for me!

    I have somewhat different experiences on that.

    On my site the problem occurs also with the “add link” button (or shift-alt-a on the mac). The window is blank, although I can close it. I also had this behavior with WP 2.4.

    The solution I ran over was: In the blog settings I had http://mysite.tld instead of http://WWW.mysite.tld. Since I changed that, all is sugar.

    BUT NOT QUITE – I was just lucky 🙂 . I usually edit my wp-admin stuff with https. With HTTPS the window is still blank, with HTTP it works fine.

    Can anyone confirm this, maybe?

    Everyone: I’ve got the fix:

    Check your browser’s address bar at the top (where your address is)

    If you’re coming from any site that uses a masked forwarded domain, it won’t work. When you insert media into post while your browser’s address bar has the same domain name in it as the one listed in your blog’s settings > General – WordPress Address URL, it will work just fine.

    I tried it with other tabs open, Firefox and Safari. I don’t think it’s browser dependent. The reason for inconsistency is probably from visiting forwarded masked domain sites, coming from frames, and all other sorts of ways in which your address bar will say something besides what it should.

    Hope this finally puts this huge issue to rest!

    Hi there everyone,

    I’m encountering this same problem in a new upgrade to 2.6.1, and the suggestions with tabs aren’t working for me… any suggestions on anything else to try?

    When I click “insert into post”, the inner window switches to my site’s 404 not found page… What am I missing?

    Many thanks in advance,

    Ok, so paying attention to this support thread:

    solution #6, with mod_security ended up solving the problem…

    here’s the answer:

    mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    That will disable mod_security for the upload file receiving code in the wp-admin directory.

    This fixed the problem of the TinyMCE popups not showing for me (found it after some more googling):

    It comes down to:
    Editing the function _print_scripts in wp-includes/script-loader.php

    function _print_scripts( $handles ) {
      global $wp_db_version;
      if ($_SERVER['HTTPS'] == 'on') $https=True; // added line
      if ($https) $src = str_replace('http://','https://',$src); // added line
      echo "<script type='text/javascript' src='$src'></script>\n";
Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Solved My “Insert Image into Post” Blank Popup Problem – Sharing’ is closed to new replies.