Support » Plugin: Admin Menu Editor » (solved) error 500 fast cgi fcgid MaxRequestLen

  • chocofc1

    (@chocofc1)


    Under apache2 and php 7.2 using mod_fcgid when you click “Save changes” you get error 500
    No explanation in Browser Console F12

    You must look at your php error.log under the vhost where error happened

    If you have:
    mod_fcgid: HTTP request length 131484 (so far) exceeds MaxRequestLen (131072)
    (*131484* can be different in your case)

    easy solve is:
    1. increase a bit upload_max_filesize in your php.ini
    upload_max_filesize = 2M (2M its default value, simply increase it to a higher value. Normally 4M will be enough. Keep in mind this value controls the max file size a user can upload in your server / website, so if plugin doesn’t restrict it, and you use a very high value here, your users will be able to upload bigger files to your server / website)

    2. increase a bit FcgidMaxRequestLen in your apache2.conf file. You can do it in your main apache2.conf file, or in each vhost you have. Normally you won’t find any line with FcgidMaxRequestLen, so you simply add it anywhere in the .conf file

    FcgidMaxRequestLen 131072 (131072 its default value, simply increase it till you can “Save changes”)

    Important note:
    Before making changes to your php.ini and apache.conf files, make a backup of them, just in case you make things worse.
    In order to Apply changes you make in php.ini and apache.conf files, you MUST RESTART apache2. You will have to login again in your wordpress site.

Viewing 1 replies (of 1 total)
  • Plugin Author Janis Elsts

    (@whiteshadow)

    I can confirm that this is a known issue with some server configurations. The menu data can be pretty large (100 KB or more), and if it exceeds the configured limit then you’ll get an error when trying to save the changes. Thank you for posting a detailed solution; it could be helpful to other users who run into this problem.

    Just to note, increasing upload_max_filesize might not work since the “Save Changes” action is technically not a file upload but a form submission. I think changing FcgidMaxRequestLen is the better option in this case.

Viewing 1 replies (of 1 total)
  • The topic ‘(solved) error 500 fast cgi fcgid MaxRequestLen’ is closed to new replies.